Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | require cairo.inc |
| 2 | |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=e73e999e0c72b5ac9012424fa157ad77" |
| 4 | |
| 5 | SRC_URI = "http://cairographics.org/releases/cairo-${PV}.tar.xz" |
| 6 | |
| 7 | SRC_URI[md5sum] = "23a0b2f0235431d35238df1d3a517fdb" |
| 8 | SRC_URI[sha256sum] = "613cb38447b76a93ff7235e17acd55a78b52ea84a9df128c3f2257f8eaa7b252" |
| 9 | |
| 10 | UPSTREAM_CHECK_REGEX = "cairo-(?P<pver>\d+(\.\d+)+)\.tar" |
| 11 | |
| 12 | PACKAGES =+ "cairo-gobject cairo-script-interpreter cairo-perf-utils" |
| 13 | |
| 14 | SUMMARY_${PN} = "The Cairo 2D vector graphics library" |
| 15 | DESCRIPTION_${PN} = "Cairo is a multi-platform library providing anti-aliased \ |
| 16 | vector-based rendering for multiple target backends. Paths consist \ |
| 17 | of line segments and cubic splines and can be rendered at any width \ |
| 18 | with various join and cap styles. All colors may be specified with \ |
| 19 | optional translucence (opacity/alpha) and combined using the \ |
| 20 | extended Porter/Duff compositing algebra as found in the X Render \ |
| 21 | Extension." |
| 22 | |
| 23 | SUMMARY_cairo-gobject = "The Cairo library GObject wrapper library" |
| 24 | DESCRIPTION_cairo-gobject = "A GObject wrapper library for the Cairo API." |
| 25 | |
| 26 | SUMMARY_cairo-script-interpreter = "The Cairo library script interpreter" |
| 27 | DESCRIPTION_cairo-script-interpreter = "The Cairo script interpreter implements \ |
| 28 | CairoScript. CairoScript is used by tracing utilities to enable the ability \ |
| 29 | to replay rendering." |
| 30 | |
| 31 | DESCRIPTION_cairo-perf-utils = "The Cairo library performance utilities" |
| 32 | |
| 33 | FILES_${PN} = "${libdir}/libcairo.so.*" |
| 34 | FILES_${PN}-dev += "${libdir}/cairo/*.so" |
| 35 | FILES_${PN}-gobject = "${libdir}/libcairo-gobject.so.*" |
| 36 | FILES_${PN}-script-interpreter = "${libdir}/libcairo-script-interpreter.so.*" |
| 37 | FILES_${PN}-perf-utils = "${bindir}/cairo-trace ${libdir}/cairo/*.la ${libdir}/cairo/libcairo-trace.so.*" |
| 38 | |
| 39 | do_install_append () { |
| 40 | rm -rf ${D}${bindir}/cairo-sphinx |
| 41 | rm -rf ${D}${libdir}/cairo/cairo-fdr* |
| 42 | rm -rf ${D}${libdir}/cairo/cairo-sphinx* |
| 43 | rm -rf ${D}${libdir}/cairo/.debug/cairo-fdr* |
| 44 | rm -rf ${D}${libdir}/cairo/.debug/cairo-sphinx* |
| 45 | } |