Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | SUMMARY = "utility functions for the Xsettings protocol" |
| 2 | DESCRIPTION = "Libraries used for applications making use of the Xsettings configuration \ |
| 3 | setting propagation protocol. Controls setting of double click timeout, drag-and-drop \ |
| 4 | threshold, and default foreground and background colors for all applications running within a \ |
| 5 | desktop." |
| 6 | HOMEPAGE = "http://matchbox-project.org/sources/optional-dependencies/" |
| 7 | BUGTRACKER = "http://bugzilla.yoctoproject.org/" |
| 8 | SECTION = "x/libs" |
| 9 | LICENSE = "MIT-style" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \ |
| 11 | file://xsettings-client.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b \ |
| 12 | file://xsettings-common.h;endline=22;md5=7cfac9d2d4dc3694cc7eb605cf32a69b" |
| 13 | DEPENDS = "virtual/libx11" |
| 14 | |
| 15 | PR = "r5" |
| 16 | |
| 17 | headers = "xsettings-common.h xsettings-client.h" |
| 18 | |
| 19 | SRC_URI = "http://downloads.yoctoproject.org/releases/matchbox/optional-dependencies/Xsettings-client-0.10.tar.gz \ |
| 20 | file://MIT-style-license \ |
| 21 | file://link-x11.patch;apply=yes \ |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 22 | file://obsolete_automake_macros.patch \ |
| 23 | " |
| 24 | |
| 25 | SRC_URI[md5sum] = "c14aa9db6c097e0306dac97fb7da1add" |
| 26 | SRC_URI[sha256sum] = "f274a4bc969ae192994a856b7f786c6fce96bae77f96c1c2b71dd97599e06e43" |
| 27 | |
| 28 | S = "${WORKDIR}/Xsettings-client-0.10" |
| 29 | |
| 30 | inherit autotools gettext distro_features_check |
| 31 | # depends on virtual/libx11 |
| 32 | REQUIRED_DISTRO_FEATURES = "x11" |
| 33 | |
| 34 | do_configure_prepend() { |
| 35 | # This package doesn't ship with its own COPYING file and |
| 36 | # autotools will install a GPLv2 one instead of the actual MIT-style license here. |
| 37 | # Add the correct license here to avoid confusion. |
| 38 | cp -f ${WORKDIR}/MIT-style-license ${S}/COPYING |
| 39 | } |
| 40 | |