Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 1 | inherit setuptools3 |
| 2 | require python-cython.inc |
| 3 | |
| 4 | RDEPENDS_${PN} += "\ |
| 5 | python3-setuptools \ |
| 6 | " |
| 7 | |
| 8 | # running build_ext a second time during install fails, because Python |
| 9 | # would then attempt to import cythonized modules built for the target |
| 10 | # architecture. |
| 11 | DISTUTILS_INSTALL_ARGS += "--skip-build" |
| 12 | |
| 13 | do_install_append() { |
| 14 | # rename scripts that would conflict with the Python 2 build of Cython |
| 15 | mv ${D}${bindir}/cython ${D}${bindir}/cython3 |
| 16 | mv ${D}${bindir}/cythonize ${D}${bindir}/cythonize3 |
| 17 | mv ${D}${bindir}/cygdb ${D}${bindir}/cygdb3 |
| 18 | } |
| 19 | |
| 20 | PACKAGEBUILDPKGD += "cython_fix_sources" |
| 21 | |
| 22 | cython_fix_sources () { |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 23 | for f in ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Compiler/FlowControl.c \ |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 24 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Compiler/FusedNode.c \ |
| 25 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Compiler/Scanning.c \ |
| 26 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Compiler/Visitor.c \ |
| 27 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Plex/Actions.c \ |
| 28 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Plex/Scanners.c \ |
| 29 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Runtime/refnanny.c \ |
| 30 | ${PKGD}/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/Cython-${PV}/Cython/Tempita/_tempita.c \ |
Andrew Geissler | 95ac1b8 | 2021-03-31 14:34:31 -0500 | [diff] [blame] | 31 | ${PKGD}${libdir}/${PYTHON_DIR}/site-packages/Cython*/SOURCES.txt; do |
| 32 | if [ -e $f ]; then |
| 33 | sed -i -e 's#${WORKDIR}#/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}#g' $f |
| 34 | fi |
| 35 | done |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 36 | } |