Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | SUMMARY = "Python Imaging Library (PIL)" |
| 2 | SECTION = "devel/python" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://README;beginline=92;endline=120;md5=c4371af4579f1e489cf881c1443dd4ec" |
| 5 | DEPENDS = "freetype jpeg tiff" |
| 6 | SRCNAME = "Imaging" |
| 7 | PR = "r5" |
| 8 | |
| 9 | SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \ |
| 10 | file://0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch \ |
| 11 | file://allow.to.disable.some.features.patch \ |
| 12 | file://fix-freetype-includes.patch \ |
| 13 | file://remove-host-libdir.patch \ |
| 14 | file://python-imaging-CVE-2016-2533.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "fc14a54e1ce02a0225be8854bfba478e" |
| 18 | SRC_URI[sha256sum] = "895bc7c2498c8e1f9b99938f1a40dc86b3f149741f105cf7c7bd2e0725405211" |
| 19 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 20 | |
| 21 | # There isn't enable/disable option, and lcms is in meta-oe, at least make it explicit when enabled |
| 22 | # setup.py already has FIXME: add mechanism to explicitly *disable* the use of a library |
| 23 | PACKAGECONFIG ??= "" |
| 24 | PACKAGECONFIG[lcms] = ",,lcms" |
| 25 | |
| 26 | inherit distutils |
| 27 | |
| 28 | do_compile() { |
| 29 | export STAGING_LIBDIR=${STAGING_LIBDIR} |
| 30 | export STAGING_INCDIR=${STAGING_INCDIR} |
| 31 | export LCMS_ENABLED=${@bb.utils.contains('PACKAGECONFIG', 'lcms', 'True', 'False', d)} |
| 32 | distutils_do_compile |
| 33 | } |
| 34 | |
| 35 | do_install() { |
| 36 | export STAGING_LIBDIR=${STAGING_LIBDIR} |
| 37 | export STAGING_INCDIR=${STAGING_INCDIR} |
| 38 | export LCMS_ENABLED=${@bb.utils.contains('PACKAGECONFIG', 'lcms', 'True', 'False', d)} |
| 39 | distutils_do_install |
| 40 | install -d ${D}${datadir}/doc/${BPN}/html/ |
| 41 | install -m 0644 ${S}/README ${D}${datadir}/doc/${BPN}/ |
| 42 | install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${BPN}/html/ |
| 43 | |
| 44 | # get rid of #!/usr/local/bin/python |
| 45 | sed -i -e 's:/usr/local/bin/:${bindir}/env :g' ${D}${bindir}/* |
| 46 | } |
| 47 | |
| 48 | RDEPENDS_${PN} += "python-lang python-stringold" |