Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A Python module for working with OpenPGP messages" |
| 2 | DESCRIPTION = "PyGPGME is a Python module that lets you sign, verify, \ |
| 3 | encrypt and decrypt messages using the OpenPGP format." |
| 4 | HOMEPAGE = "https://launchpad.net/pygpgme" |
| 5 | |
| 6 | LICENSE = "LGPL-2.1" |
| 7 | LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=6517bdc8f2416f27ab725d4702f7aac3" |
| 8 | |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 9 | SRC_URI = "file://run-ptest \ |
| 10 | file://0001-reflect-2.1-reporting-for-key-imports.patch \ |
| 11 | file://0002-passphrase_cb-is-deprecated.patch \ |
| 12 | file://0003-handle-generic-error-when-no-passphrase-callback-pre.patch \ |
| 13 | " |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 14 | |
| 15 | SRC_URI[md5sum] = "d38355af73f0352cde3d410b25f34fd0" |
| 16 | SRC_URI[sha256sum] = "5fd887c407015296a8fd3f4b867fe0fcca3179de97ccde90449853a3dfb802e1" |
| 17 | |
| 18 | DEPENDS += "gpgme" |
| 19 | RDEPENDS_${PN} += "gnupg" |
| 20 | |
| 21 | inherit pypi setuptools ptest |
| 22 | |
| 23 | do_install_ptest(){ |
| 24 | install ${S}/test_all.py ${D}${PTEST_PATH} |
| 25 | cp -r ${S}/tests ${D}${PTEST_PATH} |
| 26 | } |