Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 1 | SUMMARY = "Language for writing Python extension modules" |
| 2 | DESCRIPTION = "Pyrex is a language specially designed for writing Python extension modules. \ |
| 3 | It's designed to bridge the gap between the nice, high-level, easy-to-use world of Python \ |
| 4 | and the messy, low-level world of C." |
| 5 | SECTION = "devel/python" |
| 6 | LICENSE = "Apache-2.0" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=771d472f53f933033f57eeee7808e5bd" |
| 8 | SRCNAME = "Pyrex" |
| 9 | PR = "r4" |
| 10 | |
| 11 | SRC_URI = "\ |
| 12 | http://www.cosc.canterbury.ac.nz/greg.ewing/python/${SRCNAME}/${SRCNAME}-${PV}.tar.gz \ |
| 13 | file://pyrex-fix-optimized-mode.patch \ |
| 14 | " |
| 15 | |
| 16 | SRC_URI[md5sum] = "515dee67d15d4393841e2d60e8341947" |
| 17 | SRC_URI[sha256sum] = "5f87df06831d0b3412eb4bc9d3fc2ee7bfae1b913d7da8c23ab2bf5699fb6b50" |
| 18 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 19 | |
| 20 | inherit distutils |
| 21 | |
| 22 | FILES_${PN} += "${datadir}${base_libdir}/${PYTHON_DIR}/site-packages/Pyrex/Compiler/Lexicon.pickle" |