Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | require u-boot-common_${PV}.inc |
| 2 | |
| 3 | SUMMARY = "U-Boot bootloader image creation tool" |
| 4 | DEPENDS += "openssl" |
| 5 | |
| 6 | EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1' |
| 7 | EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1' |
| 8 | EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1' |
| 9 | |
| 10 | do_compile () { |
| 11 | oe_runmake sandbox_defconfig |
| 12 | |
| 13 | # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and |
| 14 | # generating it requires bin2header tool, which for target build |
| 15 | # is built with target tools and thus cannot be executed on host. |
| 16 | sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config |
| 17 | |
| 18 | oe_runmake cross_tools NO_SDL=1 |
| 19 | } |
| 20 | |
| 21 | do_install () { |
| 22 | install -d ${D}${bindir} |
| 23 | install -m 0755 tools/mkimage ${D}${bindir}/uboot-mkimage |
| 24 | ln -sf uboot-mkimage ${D}${bindir}/mkimage |
| 25 | } |
| 26 | |
| 27 | RDEPENDS_${PN} += "dtc" |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |