Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 1 | SUMMARY = "GNOME editor" |
| 2 | SECTION = "x11/gnome" |
| 3 | LICENSE = "GPLv2+" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e" |
| 5 | |
| 6 | GNOMEBASEBUILDCLASS = "meson" |
| 7 | |
| 8 | DEPENDS = " \ |
| 9 | yelp-tools-native \ |
| 10 | libxml2-native \ |
| 11 | gdk-pixbuf-native \ |
| 12 | iso-codes \ |
| 13 | gtk+3 \ |
| 14 | gsettings-desktop-schemas \ |
| 15 | gtksourceview4 \ |
| 16 | libpeas \ |
| 17 | libsoup-2.4 \ |
| 18 | gspell \ |
| 19 | gtksourceview4 \ |
| 20 | " |
| 21 | |
Brad Bishop | 8410d61 | 2019-11-25 09:40:59 -0500 | [diff] [blame] | 22 | inherit gnomebase gsettings itstool gnome-help gobject-introspection gtk-doc vala gettext features_check upstream-version-is-even |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 23 | |
| 24 | REQUIRED_DISTRO_FEATURES = "x11" |
| 25 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 26 | SRC_URI[archive.md5sum] = "4bca1d0a13db186cd84619b4bff42238" |
| 27 | SRC_URI[archive.sha256sum] = "ebf9ef4e19831699d26bb93ce029edfed65416d7c11147835fc370d73428d5c6" |
Brad Bishop | 23eaf03 | 2019-11-20 05:15:02 -0500 | [diff] [blame] | 28 | |
| 29 | GTKDOC_MESON_OPTION = "documentation" |
| 30 | |
| 31 | PACKAGECONFIG ??= "gvfs" |
| 32 | PACKAGECONFIG[gvfs] = "-Denable-gvfs-metadata=yes,-Denable-gvfs-metadata=no,,gvfs" |
| 33 | |
| 34 | PACKAGES += "${PN}-python" |
| 35 | |
| 36 | FILES_${PN} += " \ |
| 37 | ${datadir}/dbus-1 \ |
| 38 | ${datadir}/metainfo \ |
| 39 | " |
| 40 | |
| 41 | FILES_${PN}-python += " \ |
| 42 | ${PYTHON_SITEPACKAGES_DIR} \ |
| 43 | " |
| 44 | |