Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "interface to seccomp filtering mechanism" |
| 2 | DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp." |
| 3 | SECTION = "security" |
| 4 | LICENSE = "LGPL-2.1" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f" |
| 6 | |
Brad Bishop | 9a53395 | 2019-12-19 16:39:26 -0500 | [diff] [blame] | 7 | SRCREV = "1b6cfd1fc0b7499a28c24299a93a80bd18619563" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | |
| 9 | SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.4 \ |
Brad Bishop | 9a53395 | 2019-12-19 16:39:26 -0500 | [diff] [blame] | 10 | file://0001-tests-rely-on-__SNR_xxx-instead-of-__NR_xxx-for-sysc.patch \ |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit autotools-brokensep pkgconfig ptest |
| 17 | |
| 18 | PACKAGECONFIG ??= "" |
| 19 | PACKAGECONFIG[python] = "--enable-python, --disable-python, python" |
| 20 | |
Brad Bishop | 1fdf4aa | 2019-09-09 14:56:41 -0400 | [diff] [blame] | 21 | DISABLE_STATIC = "" |
| 22 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 23 | do_compile_ptest() { |
| 24 | oe_runmake -C tests check-build |
| 25 | } |
| 26 | |
| 27 | do_install_ptest() { |
| 28 | install -d ${D}${PTEST_PATH}/tests |
| 29 | install -d ${D}${PTEST_PATH}/tools |
| 30 | for file in $(find tests/* -executable -type f); do |
| 31 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 32 | done |
| 33 | for file in $(find tests/*.tests -type f); do |
| 34 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 35 | done |
| 36 | for file in $(find tools/* -executable -type f); do |
| 37 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools |
| 38 | done |
| 39 | } |
| 40 | |
| 41 | FILES_${PN} = "${bindir} ${libdir}/${BPN}.so*" |
| 42 | FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug" |
| 43 | |
| 44 | RDEPENDS_${PN}-ptest = "bash" |