Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | # Add MicroBlaze Patches (only when using MicroBlaze) |
| 2 | FILESEXTRAPATHS_append_microblaze := "${THISDIR}/gcc-8:" |
| 3 | SRC_URI_append_microblaze = " \ |
| 4 | file://0001-LOCAL-Testsuite-builtins-tests-require-fpic.patch \ |
| 5 | file://0002-LOCAL-Quick-fail-g-.dg-opt-memcpy1.C.patch \ |
| 6 | file://0003-LOCAL-Testsuite-explicitly-add-fivopts-for-tests-tha.patch \ |
| 7 | file://0004-LOCAL-For-dejagnu-static-testing-on-qemu-suppress-wa.patch \ |
| 8 | file://0005-Patch-testsuite-Add-MicroBlaze-to-target-supports-fo.patch \ |
| 9 | file://0006-Patch-testsuite-Update-MicroBlaze-strings-test.patch \ |
| 10 | file://0007-Patch-testsuite-Allow-MicroBlaze-.weakext-pattern-in.patch \ |
| 11 | file://0008-Patch-testsuite-Add-MicroBlaze-to-check_profiling_av.patch \ |
| 12 | file://0009-Patch-microblaze-Fix-atomic-side-effects.patch \ |
| 13 | file://0010-Patch-microblaze-Fix-atomic-boolean-return-value.patch \ |
| 14 | file://0011-Patch-microblaze-Fix-the-Microblaze-crash-with-msmal.patch \ |
| 15 | file://0012-Patch-microblaze-Added-ashrsi3_with_size_opt.patch \ |
| 16 | file://0013-Patch-microblaze-Fixed-missing-save-of-r18-in-fast_i.patch \ |
| 17 | file://0014-Patch-microblaze-Use-bralid-for-profiler-calls.patch \ |
| 18 | file://0015-Patch-microblaze-Disable-fivopts-by-default.patch \ |
| 19 | file://0016-Patch-microblaze-Removed-moddi3-routinue.patch \ |
| 20 | file://0017-Patch-microblaze-Add-INIT_PRIORITY-support.patch \ |
| 21 | file://0018-Patch-microblaze-Add-optimized-lshrsi3.patch \ |
| 22 | file://0019-Patch-microblaze-Modified-trap-instruction.patch \ |
| 23 | file://0020-Patch-microblaze-Reducing-Stack-space-for-arguments.patch \ |
| 24 | file://0021-Patch-microblaze-Add-cbranchsi4_reg.patch \ |
| 25 | file://0022-Patch-microblaze-Inline-Expansion-of-fsqrt-builtin.patch \ |
| 26 | file://0023-Patch-OPT-Update-heuristics-for-loop-invariant-for-a.patch \ |
| 27 | file://0024-PATCH-microblaze.md-Improve-adddi3-and-subdi3-insn-d.patch \ |
| 28 | file://0025-Patch-microblaze-Update-ashlsi3-movsf-patterns.patch \ |
| 29 | file://0026-Patch-microblaze-8-stage-pipeline-for-microblaze.patch \ |
| 30 | file://0027-Patch-rtl-Optimization-Better-register-pressure-esti.patch \ |
| 31 | file://0028-Patch-microblaze-Correct-the-const-high-double-immed.patch \ |
| 32 | file://0029-Fix-microblaze-Fix-internal-compiler-error-with-msma.patch \ |
| 33 | file://0030-patch-microblaze-Fix-the-calculation-of-high-word-in.patch \ |
| 34 | file://0031-Patch-microblaze-Add-new-bit-field-instructions.patch \ |
| 35 | file://0032-Patch-microblaze-Fix-bug-in-MB-version-calculation.patch \ |
| 36 | file://0033-Fixing-the-bug-in-the-bit-field-instruction.patch \ |
| 37 | file://0034-Patch-microblaze-Macros-used-in-Xilinx-internal-patc.patch \ |
| 38 | file://0035-Fixing-the-issue-with-the-builtin_alloc.patch \ |
| 39 | file://0036-Patch-Microblaze-reverting-the-cost-check-before-pro.patch \ |
| 40 | file://0037-Patch-Microblaze-update-in-constraints-for-bitfield-.patch \ |
| 41 | file://0038-Patch-Microblaze-Removed-fsqrt-generation-for-double.patch \ |
| 42 | file://0039-Intial-commit-of-64-bit-Microblaze.patch \ |
| 43 | file://0040-Added-load-store-pattern-movdi-and-also-adding-missi.patch \ |
| 44 | file://0041-Intial-commit-for-64bit-MB-sources.patch \ |
| 45 | file://0042-re-arrangement-of-the-compare-branches.patch \ |
| 46 | file://0043-Patch-Microblaze-previous-commit-broke-the-handling-.patch \ |
| 47 | file://0044-Patch-Microblaze-Support-of-multilibs-with-m64.patch \ |
| 48 | file://0045-Fixed-issues-like.patch \ |
| 49 | file://0046-Fixed-below-issues.patch \ |
| 50 | file://0047-Added-double-arith-instructions.patch \ |
| 51 | file://0048-Fixed-the-issue-in-the-delay-slot-with-swap-instruct.patch \ |
| 52 | file://0049-Fixed-the-load-store-issue-with-the-32bit-arith-libr.patch \ |
| 53 | file://0050-extending-the-Dwarf-support-to-64bit-Microblaze.patch \ |
| 54 | file://0051-fixing-the-typo-errors-in-umodsi3-file.patch \ |
| 55 | file://0052-fixing-the-32bit-LTO-related-issue9-1014024.patch \ |
| 56 | file://0053-Fixed-the-missing-stack-adjustment-in-prologue-of-mo.patch \ |
| 57 | file://0054-Patch-Microblaze-corrected-SPN-for-dlong-instruction.patch \ |
| 58 | file://0055-fixing-the-long-long-long-mingw-toolchain-issue.patch \ |
| 59 | file://0057-Fix-the-MB-64-bug-of-handling-QI-objects.patch \ |
| 60 | file://0058-Patch-Microblaze-We-will-check-the-possibility-of-pe.patch \ |
| 61 | file://0059-Reverting-the-patch-as-kernel-boot-is-not-working-wi.patch \ |
| 62 | file://0060-Patch-MicroBlaze-fixed-typos-in-mul-div-and-mod-asse.patch \ |
| 63 | file://0061-Author-Nagaraju-nmekala-xilinx.com.patch \ |
| 64 | file://0055-microblaze_linker_script_xilinx_ld.patch \ |
| 65 | " |