Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SECTION = "console/network" |
| 2 | SUMMARY = "dhcpcd - a DHCP client" |
| 3 | DESCRIPTION = "dhcpcd runs on your machine and silently configures your computer to work on the attached networks without trouble and mostly without configuration." |
| 4 | |
| 5 | HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/" |
| 6 | |
| 7 | LICENSE = "BSD-2-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0531457992a97ecebc6975914a874a9d" |
| 9 | |
| 10 | UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/" |
| 11 | |
| 12 | SRC_URI = "http://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \ |
| 13 | file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch" |
| 14 | |
| 15 | SRC_URI[md5sum] = "e1eea03388d12c9ad21ecd7c135fdf8b" |
| 16 | SRC_URI[sha256sum] = "6c2934a3e1e67a5cfd5bb15b1efa71f65c00314ac1ccb5c50da8eae3a0b8147f" |
| 17 | |
| 18 | inherit pkgconfig autotools-brokensep |
| 19 | |
| 20 | PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 21 | |
| 22 | PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev" |
| 23 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6" |
| 24 | |
| 25 | EXTRA_OECONF = "--enable-ipv4" |
| 26 | |
| 27 | FILES_${PN}-dbg += "${libdir}/dhcpcd/dev/.debug" |