blob: ff7a4ed10582540ec40b9ff997a6ed9940bb3123 [file] [log] [blame]
Patrick Williamsddad1a12017-02-23 20:36:32 -06001# Copyright (c) 2013 LG Electronics, Inc.
2
3SUMMARY = "libnih library"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05004HOMEPAGE = "https://launchpad.net/libnih"
Patrick Williamsddad1a12017-02-23 20:36:32 -06005DESCRIPTION = "libnih is a small library for C application development \
6 containing functions that, despite its name, are not implemented \
7 elsewhere in the standard library set. \
8 \
9 libnih is roughly equivalent to other C libraries such as glib, \
10 except that its focus is on a small size and intended for \
11 applications that sit very low in the software stack, especially \
12 outside of /usr. \
13 \
14 It expressly does not reimplement functions that already exist in \
15 libraries ordinarily shipped in /lib such libc6, and does not do \
16 foolish things like invent arbitrary typedefs for perfectly good C types."
17
18SECTION = "libs"
19
20LICENSE = "GPL-2.0"
21LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
22
Brad Bishope42b3e32020-01-15 22:08:42 -050023DEPENDS = "dbus expat"
24DEPENDS_append_class-target = " libnih-native"
Patrick Williamsddad1a12017-02-23 20:36:32 -060025
26SRC_URI = "https://launchpad.net/${BPN}/1.0/${PV}/+download/${BP}.tar.gz \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027 file://libnih_1.0.3-4ubuntu16.patch \
28 file://0001-signal.c-SIGCLD-and-SIGCHILD-are-same-on-sytem-V-sys.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050029 file://0001-Update-autotool-files-also-make-it-work-with-latest-.patch \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050030 "
Patrick Williamsddad1a12017-02-23 20:36:32 -060031
32SRC_URI[md5sum] = "db7990ce55e01daffe19006524a1ccb0"
33SRC_URI[sha256sum] = "897572df7565c0a90a81532671e23c63f99b4efde2eecbbf11e7857fbc61f405"
34
Brad Bishope42b3e32020-01-15 22:08:42 -050035inherit autotools gettext
Patrick Williamsddad1a12017-02-23 20:36:32 -060036
Armin Kuster066be202018-07-08 14:58:53 -070037do_configure_append () {
38 sed -i -e 's,lib/pkgconfig,${baselib}/pkgconfig,g' ${S}/nih/Makefile.in ${S}/nih-dbus/Makefile.in
39}
40
41FILES_${PN}-dev += "${libdir}/pkgconfig/* \
42 ${includedir}/* \
43 ${libdir}/*.so \
44 ${datadir}/* \
45 "
46
Patrick Williamsddad1a12017-02-23 20:36:32 -060047# target libnih requires native nih-dbus-tool
48BBCLASSEXTEND = "native"