William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 1 | # |
| 2 | # Copyright (C) 2014 Wind River Systems, Inc. |
| 3 | # Released under the BSD-3-Clause license (see COPYING.BSD-3 for the terms) |
| 4 | # |
| 5 | SUMMARY = "A compression/decompression library" |
| 6 | DESCRIPTION = "Snappy is a fast data compression and decompression library \ |
| 7 | It was designed to be very fast and stable, but not to achieve a high \ |
| 8 | compression ratio." |
| 9 | |
| 10 | LICENSE = "BSD-3-Clause" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=f62f3080324a97b3159a7a7e61812d0c" |
| 12 | |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 13 | SRC_URI = "gitsm://github.com/google/snappy.git;protocol=https;branch=main \ |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 14 | file://fix-build-on-32bit-arm.patch" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 15 | |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 16 | SRCREV = "dc05e026488865bc69313a68bcc03ef2e4ea8e83" |
| 17 | |
| 18 | S = "${WORKDIR}/git" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 19 | |
| 20 | inherit cmake pkgconfig |
| 21 | |
| 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[lzo] = "-DHAVE_LIBLZO2=1,-DHAVE_LIBLZO2=0,lzo," |
| 24 | TARGET_CFLAGS += "-fPIC" |
| 25 | |
| 26 | EXTRA_OECMAKE += '-DBUILD_SHARED_LIBS="ON" -DSNAPPY_BUILD_TESTS="OFF" -DSNAPPY_BUILD_BENCHMARKS="OFF"' |
Andrew Geissler | 5082cc7 | 2023-09-11 08:41:39 -0400 | [diff] [blame] | 27 | |
| 28 | CVE_PRODUCT = "google:snappy" |