Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "Persistent Memory Development Kit" |
| 2 | DESCRIPTION = "Persistent Memory Development Kit" |
| 3 | HOMEPAGE = "http://pmem.io" |
| 4 | SECTION = "libs" |
| 5 | LICENSE = "BSD-3-Clause" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b44ee63f162f9cdb18fff1224877aafd" |
| 7 | DEPENDS = "ndctl" |
| 8 | |
| 9 | # Required to have the fts.h header for musl |
| 10 | DEPENDS:append:libc-musl = " fts" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 14 | SRC_URI = "git://github.com/pmem/pmdk.git;branch=stable-1.11;protocol=https \ |
| 15 | file://0001-use-daxctl-libdaxctl.h-instead-of-ndctl-libdaxctl.h.patch" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 16 | SRCREV = "5b21904a257eff47f2e87fcbf2de46111f03ddd8" |
| 17 | |
| 18 | inherit autotools-brokensep pkgconfig |
| 19 | |
| 20 | # Fix jemalloc error: |
| 21 | # | configure: error: cannot run C compiled programs. |
| 22 | # | If you meant to cross compile, use `--host'. |
| 23 | # |
| 24 | # Also fix #warning _FORTIFY_SOURCE requires compiling with optimization (-O) [-Werror=cpp] |
| 25 | EXTRA_OEMAKE = "BUILD_EXAMPLES='n' DOC='n' HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECTED_OPTIMIZATION}' LIB_PREFIX=${baselib}" |
| 26 | |
| 27 | # Fix the missing fts libs when using musl |
| 28 | EXTRA_OEMAKE:append:libc-musl = " EXTRA_LIBS='-lfts'" |
| 29 | |
| 30 | do_configure:prepend() { |
| 31 | touch .skip-doc |
| 32 | } |
| 33 | |
| 34 | do_install() { |
| 35 | oe_runmake prefix=${prefix} DESTDIR=${D} install |
| 36 | |
| 37 | # Remove uneeded files |
| 38 | rm -rf ${D}/usr/${baselib}/pmdk_debug |
| 39 | } |
| 40 | |
| 41 | # Include these by default otherwise the SDK is not very useful |
| 42 | FILES:${PN} += "${bindir}/pmempool ${bindir}/daxio" |
| 43 | FILES:${PN} += "${libdir}/*so*" |
| 44 | FILES:${PN} += "${libdir}/pkgconfig/*.pc" |
| 45 | FILES:${PN} += "${includedir}/libpmemobj++/* ${includedir}/libpmemobj/* /usr/*/include/" |
| 46 | FILES:${PN} += "/usr/etc" |
| 47 | FILES:${PN} += "/usr/share" |
| 48 | |
| 49 | COMPATIBLE_HOST='(x86_64).*' |