blob: 95ebcabf36f5be437c484ffe8d96d13a71ac2ca3 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "The Illume Windowing Environment -- install this task to get the Enlightenment Window Manager + the Illume environment."
2SECTION = "x11/wm"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${TOPDIR}/meta-openembedded/meta-efl/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5PV = "1.0"
6PR = "r5"
7
8inherit packagegroup allarch
9
10# Default theme and config
11ETHEME ?= "e-wm-theme-default"
12ECONFIG ?= "e-wm-config-mobile"
13
14RRECOMMENDS_${PN} = "\
15 ${ETHEME} \
16"
17
18RDEPENDS_${PN} = "\
19 packagegroup-core-x11-xserver \
20 packagegroup-core-x11-utils \
21 \
22 e-wm \
23 ${ECONFIG} \
24"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
26PNBLACKLIST[packagegroup-x11-illume] ?= "Runtime depends on blacklisted e-wm - the recipe will be removed on 2017-09-01 unless the issue is fixed"
27
28PNBLACKLIST[packagegroup-x11-illume] ?= "Runtime depends on blacklisted e-wm-config-mobile - the recipe will be removed on 2017-09-01 unless the issue is fixed"
29
30PNBLACKLIST[packagegroup-x11-illume] ?= "Runtime depends on blacklisted e-wm-theme-default - the recipe will be removed on 2017-09-01 unless the issue is fixed"