Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Provides a way to load and enumerate PKCS#11 modules" |
| 2 | DESCRIPTION = " Provides a standard configuration setup for installing PKCS#11 modules in such a way that they're discoverable. Also solves problems with coordinating the use of PKCS#11 by different components or libraries living in the same process." |
| 3 | HOMEPAGE = "https://p11-glue.github.io/p11-glue/p11-kit.html" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50" |
| 6 | |
| 7 | inherit meson gettext pkgconfig gtk-doc bash-completion manpages |
| 8 | |
| 9 | DEPENDS = "libtasn1 libtasn1-native libffi" |
| 10 | |
| 11 | DEPENDS:append = "${@' glib-2.0' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}" |
| 12 | |
| 13 | SRC_URI = "git://github.com/p11-glue/p11-kit;branch=master;protocol=https" |
| 14 | SRCREV = "dd0590d4e583f107e3e9fafe9ed754149da335d0" |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | PACKAGECONFIG ??= "" |
| 18 | PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native" |
| 19 | PACKAGECONFIG[trust-paths] = "-Dtrust_paths=/etc/ssl/certs/ca-certificates.crt,,,ca-certificates" |
| 20 | |
| 21 | GTKDOC_MESON_OPTION = 'gtk_doc' |
| 22 | |
| 23 | FILES:${PN} += " \ |
| 24 | ${libdir}/p11-kit-proxy.so \ |
| 25 | ${libdir}/pkcs11/*.so \ |
| 26 | ${libdir}/pkcs11/*.la \ |
| 27 | ${systemd_user_unitdir}/*" |
| 28 | |
| 29 | # PN contains p11-kit-proxy.so, a symlink to a loadable module |
| 30 | INSANE_SKIP:${PN} = "dev-so" |
| 31 | |
| 32 | BBCLASSEXTEND = "nativesdk" |