blob: b97697db2e9695b729f9e8834816407599348e04 [file] [log] [blame]
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +08001FILESEXTRAPATHS:prepend := "${THISDIR}/files:"
2
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +08003SRC_URI += " \
4 file://setup-local-eid.conf \
Chris Wang062def22024-04-10 16:35:42 +08005 file://setup-static-endpoints.conf \
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +08006 file://mctp-config.sh \
Chris Wang062def22024-04-10 16:35:42 +08007 file://setup-static-endpoints.sh \
Delphine CC Chiu5c7dabe2023-12-15 17:58:13 +08008 file://nic-gpio-addrs.sh \
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +08009"
10
11FILES:${PN} += "${systemd_system_unitdir}/*"
12
13do_install:append () {
14 override_dir=${D}${systemd_system_unitdir}/mctpd.service.d
15 install -d ${D}${systemd_system_unitdir}/mctpd.service.d
Patrick Williams5b984e62024-08-26 14:42:52 -040016
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +080017 install -m 0644 ${WORKDIR}/setup-local-eid.conf \
18 ${override_dir}/setup-local-eid.conf
Chris Wang062def22024-04-10 16:35:42 +080019 install -m 0644 ${WORKDIR}/setup-static-endpoints.conf \
20 ${override_dir}/setup-static-endpoints.conf
Patrick Williams5b984e62024-08-26 14:42:52 -040021
22 install -d ${D}${libexecdir}/mctp
23
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +080024 install -m 0755 ${WORKDIR}/mctp-config.sh \
Patrick Williams5b984e62024-08-26 14:42:52 -040025 ${D}${libexecdir}/mctp/
Chris Wang062def22024-04-10 16:35:42 +080026 install -m 0755 ${WORKDIR}/setup-static-endpoints.sh \
Patrick Williams5b984e62024-08-26 14:42:52 -040027 ${D}${libexecdir}/mctp/
Delphine CC Chiu5c7dabe2023-12-15 17:58:13 +080028 install -m 0755 ${WORKDIR}/nic-gpio-addrs.sh \
Patrick Williams5b984e62024-08-26 14:42:52 -040029 ${D}${libexecdir}/mctp/
Delphine CC Chiu99be5bc32023-12-11 13:56:32 +080030}