Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "A collection of ASN.1-based protocols modules." |
| 2 | DESCRIPTION = "A collection of ASN.1 modules expressed in form of pyasn1\ |
| 3 | classes. Includes protocols PDUs definition (SNMP, LDAP etc.) and various\ |
| 4 | data structures (X.509, PKCS etc.)." |
| 5 | HOMEPAGE = "https://github.com/etingof/pyasn1-modules" |
| 6 | LICENSE = "BSD-2-Clause" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 7 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a14482d15c2249de3b6f0e8a47e021fd" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 8 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 9 | SRC_URI[md5sum] = "107e1ece7d0a41d782f69f8a95a4d9bc" |
| 10 | SRC_URI[sha256sum] = "905f84c712230b2c592c19470d3ca8d552de726050d1d1716282a1f6146be65e" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | |
Andrew Geissler | d221e03 | 2020-07-10 16:13:21 -0500 | [diff] [blame] | 12 | inherit pypi ptest setuptools3 |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 13 | |
| 14 | RDEPENDS_${PN} = "${PYTHON_PN}-pyasn1" |
| 15 | |
| 16 | BBCLASSEXTEND = "native nativesdk" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
| 18 | SRC_URI += " \ |
| 19 | file://run-ptest \ |
| 20 | " |
| 21 | |
| 22 | RDEPENDS_${PN}-ptest += " \ |
| 23 | ${PYTHON_PN}-pytest \ |
| 24 | " |
| 25 | |
| 26 | do_install_ptest() { |
| 27 | install -d ${D}${PTEST_PATH}/tests |
| 28 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 29 | } |