Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GStreamer 1.0 multimedia framework" |
| 2 | DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \ |
| 3 | It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime." |
| 4 | HOMEPAGE = "http://gstreamer.freedesktop.org/" |
| 5 | BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer" |
| 6 | SECTION = "multimedia" |
| 7 | LICENSE = "LGPLv2+" |
| 8 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 9 | DEPENDS = "glib-2.0 glib-2.0-native libxml2 bison-native flex-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 11 | inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 12 | |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d \ |
| 14 | file://gst/gst.h;beginline=1;endline=21;md5=e059138481205ee2c6fc1c079c016d0d" |
| 15 | |
| 16 | S = "${WORKDIR}/gstreamer-${PV}" |
| 17 | |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 18 | SRC_URI = "https://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.xz \ |
| 19 | file://0001-gst-gstpluginloader.c-when-env-var-is-set-do-not-fal.patch \ |
| 20 | file://0002-Remove-unused-valgrind-detection.patch \ |
| 21 | file://0003-meson-Add-option-for-installed-tests.patch \ |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 22 | file://0001-tests-seek-Don-t-use-too-strict-timeout-for-validati.patch \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 23 | " |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 24 | SRC_URI[sha256sum] = "0c2e09e18f2df69a99b5cb3bd53c597b3cc2e35cf6c98043bb86a66f3d312100" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 25 | |
| 26 | PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)} \ |
| 27 | check \ |
| 28 | debug \ |
| 29 | tools" |
| 30 | |
| 31 | PACKAGECONFIG[debug] = "-Dgst_debug=true,-Dgst_debug=false" |
| 32 | PACKAGECONFIG[tracer-hooks] = "-Dtracer_hooks=true,-Dtracer_hooks=false" |
| 33 | PACKAGECONFIG[check] = "-Dcheck=enabled,-Dcheck=disabled" |
| 34 | PACKAGECONFIG[tests] = "-Dtests=enabled -Dinstalled-tests=true,-Dtests=disabled -Dinstalled-tests=false" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 35 | PACKAGECONFIG[unwind] = "-Dlibunwind=enabled,-Dlibunwind=disabled,libunwind" |
| 36 | PACKAGECONFIG[dw] = "-Dlibdw=enabled,-Dlibdw=disabled,elfutils" |
| 37 | PACKAGECONFIG[bash-completion] = "-Dbash-completion=enabled,-Dbash-completion=disabled,bash-completion" |
| 38 | PACKAGECONFIG[tools] = "-Dtools=enabled,-Dtools=disabled" |
Andrew Geissler | d1e8949 | 2021-02-12 15:35:20 -0600 | [diff] [blame] | 39 | PACKAGECONFIG[setcap] = "-Dptp-helper-permissions=capabilities,,libcap libcap-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 40 | |
| 41 | # TODO: put this in a gettext.bbclass patch |
| 42 | def gettext_oemeson(d): |
| 43 | if d.getVar('USE_NLS') == 'no': |
| 44 | return '-Dnls=disabled' |
| 45 | # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set |
| 46 | if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'): |
| 47 | return '-Dnls=disabled' |
| 48 | return '-Dnls=enabled' |
| 49 | |
| 50 | EXTRA_OEMESON += " \ |
Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 51 | -Ddoc=disabled \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 52 | -Dexamples=disabled \ |
| 53 | -Ddbghelp=disabled \ |
| 54 | ${@gettext_oemeson(d)} \ |
| 55 | " |
| 56 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 57 | GIR_MESON_ENABLE_FLAG = "enabled" |
| 58 | GIR_MESON_DISABLE_FLAG = "disabled" |
| 59 | |
| 60 | PACKAGES += "${PN}-bash-completion" |
| 61 | |
| 62 | # Add the core element plugins to the main package |
| 63 | FILES_${PN} += "${libdir}/gstreamer-1.0/*.so" |
| 64 | FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.a ${libdir}/gstreamer-1.0/include" |
| 65 | FILES_${PN}-bash-completion += "${datadir}/bash-completion/completions/ ${datadir}/bash-completion/helpers/gst*" |
| 66 | FILES_${PN}-dbg += "${datadir}/gdb ${datadir}/gstreamer-1.0/gdb" |
| 67 | |
| 68 | CVE_PRODUCT = "gstreamer" |
| 69 | |
| 70 | require gstreamer1.0-ptest.inc |