blob: dc681c249b14452637dbe8bafa423bd06696402f [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001# SPDX-FileCopyrightText: Huawei Inc.
2#
3# SPDX-License-Identifier: MIT
4
5HOMEPAGE = "https://lvgl.io/"
6DESCRIPTION = "LVGL is an OSS graphics library to create embedded GUI"
7SUMMARY = "Light and Versatile Graphics Library"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENCE.txt;md5=bf1198c89ae87f043108cea62460b03a"
10
Andrew Geissler3eeda902023-05-19 10:14:02 -050011SRC_URI = "git://github.com/lvgl/lvgl;protocol=https;branch=release/v8.3"
Andrew Geissler5082cc72023-09-11 08:41:39 -040012SRCREV = "9ec3b8706b098f60940cee6ac211d3cb3141aedf"
Andrew Geissler595f6302022-01-24 19:11:47 +000013
14inherit cmake
Andrew Geissler595f6302022-01-24 19:11:47 +000015
Patrick Williams8e7b46e2023-05-01 14:19:06 -050016EXTRA_OECMAKE = "-DLIB_INSTALL_DIR=${baselib}"
17S = "${WORKDIR}/git"
Andrew Geissler595f6302022-01-24 19:11:47 +000018
19LVGL_CONFIG_LV_MEM_CUSTOM ?= "0"
Andrew Geissler3eeda902023-05-19 10:14:02 -050020LVGL_CONFIG_LV_COLOR_DEPTH ?= "32"
Andrew Geissler595f6302022-01-24 19:11:47 +000021
22# Upstream does not support a default configuration
23# but propose a default "disabled" template, which is used as reference
24# More configuration can be done using external configuration variables
25do_configure:prepend() {
26 [ -r "${S}/lv_conf.h" ] \
27 || sed -e 's|#if 0 .*Set it to "1" to enable .*|#if 1 // Enabled|g' \
Andrew Geissler3eeda902023-05-19 10:14:02 -050028 -e "s|\(#define LV_COLOR_DEPTH \).*|\1 ${LVGL_CONFIG_LV_COLOR_DEPTH}|g" \
29 \
Andrew Geissler595f6302022-01-24 19:11:47 +000030 -e "s|\(#define LV_MEM_CUSTOM .*\)0|\1${LVGL_CONFIG_LV_MEM_CUSTOM}|g" \
Andrew Geissler3eeda902023-05-19 10:14:02 -050031 \
32 -e "s|\(#define LV_TICK_CUSTOM \).*|\1 1|g" \
33 -e "s|\(#define LV_TICK_CUSTOM_INCLUDE \).*|\1 <stdint.h>|g" \
34 -e "s|\(#define LV_TICK_CUSTOM_SYS_TIME_EXPR \).*|extern uint32_t custom_tick_get(void);\n\1 (custom_tick_get())|g" \
35 \
Andrew Geissler595f6302022-01-24 19:11:47 +000036 < "${S}/lv_conf_template.h" > "${S}/lv_conf.h"
37}
38
39FILES:${PN}-dev += "\
40 ${includedir}/${PN}/ \
41 ${includedir}/${PN}/lvgl/ \
42 "