Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION = "LFTP is a sophisticated file transfer program with \ |
| 2 | command line interface. It supports FTP, HTTP, \ |
| 3 | FISH, SFTP, HTTPS and FTPS protocols" |
| 4 | HOMEPAGE = "http://lftp.yar.ru/" |
| 5 | SECTION = "console/network" |
| 6 | LICENSE = "GPLv3" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504" |
| 8 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 9 | SRC_URI = "http://lftp.yar.ru/ftp/lftp-${PV}.tar.bz2" |
| 10 | SRC_URI[md5sum] = "b05817a2c26463618271730d0f677edb" |
| 11 | SRC_URI[sha256sum] = "309e7e91a7c020625715e85c1726b1e7524da22518683fbe051ac13116dedeac" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | |
| 13 | inherit autotools gettext pkgconfig |
| 14 | |
| 15 | acpaths = "-I ./m4" |
| 16 | |
| 17 | EXTRA_OECONF += "--with-modules --disable-rpath" |
| 18 | |
| 19 | PACKAGECONFIG ??= "openssl zlib gnutls readline expat" |
| 20 | PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl" |
| 21 | PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_INCDIR}/.., --without-zlib, zlib" |
| 22 | PACKAGECONFIG[gnutls] = "--with-gnutls, --without-gnutls, gnutls" |
| 23 | PACKAGECONFIG[readline] = "--with-readline=${STAGING_INCDIR}/.. --with-readline-inc=${STAGING_INCDIR} --with-readline-lib=-lreadline, --with-readline=no, readline" |
| 24 | PACKAGECONFIG[expat] = "--with-expat=${STAGING_INCDIR}/.. --with-expat-inc=${STAGING_INCDIR} --with-expat-lib=-lexpat, , expat" |
| 25 | |
| 26 | do_install_append() { |
| 27 | rm -rf ${D}${libdir}/charset.alias |
| 28 | } |
| 29 | FILES_${PN} += "${datadir}/icons/hicolor" |
| 30 | FILES_${PN}-dbg += "${libdir}/lftp/${PV}/.debug" |
| 31 | RDEPENDS_${PN} = "perl bash readline" |