blob: 40ee555db7a496f806dc1f45c9070ef513ef105f [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require recipes-graphics/xorg-app/xorg-app-common.inc
2SUMMARY = "xterm is the standard terminal emulator for the X Window System"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08003DEPENDS = "libxaw xorgproto libxext libxau libxinerama libxpm ncurses"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05004
Brad Bishop26bdd442019-08-16 17:08:17 -04005LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=c7faceb872d90115e7c0ad90e90c390d"
Brad Bishopd7bf8c12018-02-25 22:55:05 -05006
Brad Bishope42b3e32020-01-15 22:08:42 -05007SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \
8 file://0001-Add-configure-time-check-for-setsid.patch \
9 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050010
Brad Bishope42b3e32020-01-15 22:08:42 -050011SRC_URI[md5sum] = "a07edfbee2e2f4c6a9ddbf834fa4bbec"
12SRC_URI[sha256sum] = "760a8a10221c9c9744afd86db87c7ad95bbf9be4f5f525fecf39125f0d2a6e16"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050013PACKAGECONFIG ?= ""
14PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native"
15
16EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \
17 --x-libraries=${STAGING_LIBDIR} \
18 FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \
19 --disable-imake \
20 --disable-rpath-hack \
Brad Bishop26bdd442019-08-16 17:08:17 -040021 --disable-setuid \
22 --with-app-defaults=${datadir}/X11/app-defaults \
23 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024
25B = "${S}"
26
27do_configure() {
28 gnu-configize --force
29 sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure
30 oe_runconf
31}
32
Brad Bishop316dfdd2018-06-25 12:45:53 -040033# busybox can supply resize too
34inherit update-alternatives
35
36ALTERNATIVE_${PN} = "resize"