Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | require recipes-graphics/xorg-app/xorg-app-common.inc |
| 2 | SUMMARY = "xterm is the standard terminal emulator for the X Window System" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 3 | DEPENDS = "libxaw xorgproto libxext libxau libxinerama libxpm ncurses" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 4 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://xterm.h;beginline=3;endline=31;md5=c7faceb872d90115e7c0ad90e90c390d" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 6 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 7 | SRC_URI = "http://invisible-mirror.net/archives/${BPN}/${BP}.tgz \ |
| 8 | file://0001-Add-configure-time-check-for-setsid.patch \ |
| 9 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 11 | SRC_URI[md5sum] = "a07edfbee2e2f4c6a9ddbf834fa4bbec" |
| 12 | SRC_URI[sha256sum] = "760a8a10221c9c9744afd86db87c7ad95bbf9be4f5f525fecf39125f0d2a6e16" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | PACKAGECONFIG ?= "" |
| 14 | PACKAGECONFIG[xft] = "--enable-freetype,--disable-freetype,libxft fontconfig freetype-native" |
| 15 | |
| 16 | EXTRA_OECONF = " --x-includes=${STAGING_INCDIR} \ |
| 17 | --x-libraries=${STAGING_LIBDIR} \ |
| 18 | FREETYPE_CONFIG=${STAGING_BINDIR_CROSS}/freetype-config \ |
| 19 | --disable-imake \ |
| 20 | --disable-rpath-hack \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 21 | --disable-setuid \ |
| 22 | --with-app-defaults=${datadir}/X11/app-defaults \ |
| 23 | " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 24 | |
| 25 | B = "${S}" |
| 26 | |
| 27 | do_configure() { |
| 28 | gnu-configize --force |
| 29 | sed -e "s%/usr/contrib/X11R6%${STAGING_LIBDIR}%g" -i configure |
| 30 | oe_runconf |
| 31 | } |
| 32 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 33 | # busybox can supply resize too |
| 34 | inherit update-alternatives |
| 35 | |
| 36 | ALTERNATIVE_${PN} = "resize" |