blob: 44a5fea841e34eb016c2bd6c8fff86289aedd3d1 [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001DESCRIPTION = "PDF transformation/inspection software"
2HOMEPAGE = "http://qpdf.sourceforge.net"
3LICENSE = "Artistic-2.0"
4SECTION = "libs"
5DEPENDS = "libpcre zlib libjpeg-turbo"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf/qpdf-${PV}.tar.gz"
8
9LIC_FILES_CHKSUM = "file://Artistic-2.0;md5=7806296b9fae874361e6fb10072b7ee3"
10SRC_URI[md5sum] = "090d03ab179c281233f8240ade179d54"
11SRC_URI[sha256sum] = "3abbbb7907f2e750336b9c97e67b6e806aca91ab537402ec080656d63940ed79"
12
13inherit autotools-brokensep gettext
14
15# disable random file detection for cross-compile
16EXTRA_OECONF = "--without-random \
17 --disable-static \
18 --disable-check-autofiles \
19 "
20
21EXTRA_OEMAKE_class-target = "LIBTOOL=${HOST_SYS}-libtool"
22
23S="${WORKDIR}/${BPN}-${PV}"
24
25# avoid Makefile returning error on 'make clean' before configure was run
26CLEANBROKEN = "1"
27
28DEBIAN_NOAUTONAME_libqpdf = "1"
29
30PACKAGES =+ "libqpdf"
31FILES_libqpdf = "${libdir}/libqpdf.so.*"
32
33RDEPEND_${PN} = "libqpdf"