blob: dd129cbec98067e7fbf1aa6dff28ee9b593ac103 [file] [log] [blame]
William A. Kennington III via Openembedded-develd25baec2019-01-15 16:48:56 -08001SUMMARY = "C++11 command line parser"
2DESCRIPTION = "A command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface."
3HOMEPAGE = "https://github.com/CLIUtils/CLI11"
4LICENSE = "BSD-3-Clause"
Brad Bishop26bdd442019-08-16 17:08:17 -04005LIC_FILES_CHKSUM = "file://LICENSE;md5=b73927b18d5c6cd8d2ed28a6ad539733"
6SRCREV = "13becaddb657eacd090537719a669d66d393b8b2"
William A. Kennington III via Openembedded-develd25baec2019-01-15 16:48:56 -08007PV .= "+git${SRCPV}"
8
Brad Bishop19323692019-04-05 15:28:33 -04009SRC_URI += "gitsm://github.com/CLIUtils/CLI11 \
10 file://0001-Add-CLANG_TIDY-check.patch \
Brad Bishope42b3e32020-01-15 22:08:42 -050011 file://0001-Use-GNUInstallDirs-instead-of-hard-coded-path.patch \
Brad Bishop19323692019-04-05 15:28:33 -040012 "
William A. Kennington III via Openembedded-develd25baec2019-01-15 16:48:56 -080013
14S = "${WORKDIR}/git"
15
16inherit cmake
17inherit ptest
18
Brad Bishop19323692019-04-05 15:28:33 -040019EXTRA_OECMAKE += "-DCLANG_TIDY=OFF"
William A. Kennington III via Openembedded-develd25baec2019-01-15 16:48:56 -080020DEPENDS += "boost"
Brad Bishop90ca7472019-08-20 09:15:15 -040021
22# cli11 is a header only C++ library, so the main package will be empty.
23RDEPENDS_${PN}-dev = ""