Brad Bishop | 34ae600 | 2019-04-08 15:21:03 -0400 | [diff] [blame] | 1 | SUMMARY = "Fast Artificial Neural Network (FANN) Library" |
| 2 | DESCRIPTION = "Fast Artificial Neural Network (FANN) Library is a free open source neural network library, which implements multilayer artificial neural networks in C with support for both fully connected and sparsely connected networks." |
| 3 | HOMEPAGE = "https://github.com/libfann/fann" |
| 4 | SECTION = "libs/devel" |
| 5 | |
| 6 | LICENSE = "LGPLv2.1" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=f14599a2f089f6ff8c97e2baa4e3d575" |
| 8 | |
| 9 | inherit cmake |
| 10 | |
| 11 | SRCREV ?= "7ec1fc7e5bd734f1d3c89b095e630e83c86b9be1" |
| 12 | SRC_URI = "git://github.com/libfann/fann.git;branch=master \ |
| 13 | " |
| 14 | |
| 15 | PV = "2.2.0+git${SRCPV}" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 18 | |
| 19 | EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}" |