Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame^] | 1 | DESRIPTION = "2D barcode scanner toolkit." |
| 2 | SECTION = "graphics" |
| 3 | LICENSE = "LGPL-2.1" |
| 4 | |
| 5 | DEPENDS = "pkgconfig intltool-native libpng jpeg" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=4015840237ca7f0175cd626f78714ca8" |
| 8 | |
| 9 | PV = "0.10+git${SRCPV}" |
| 10 | |
| 11 | # iPhoneSDK-1.3.1 tag |
| 12 | SRCREV = "67003d2a985b5f9627bee2d8e3e0b26d0c474b57" |
| 13 | SRC_URI = "git://github.com/ZBar/Zbar \ |
| 14 | file://0001-make-relies-GNU-extentions.patch \ |
| 15 | " |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit autotools pkgconfig |
| 19 | |
| 20 | PACKAGECONFIG = "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" |
| 21 | |
| 22 | PACKAGECONFIG[x11] = "--with-x,-without-x,libxcb libx11 libsm libxau libxext libxv libice libxdmcp" |
| 23 | |
| 24 | EXTRA_OECONF = "--without-imagemagick --without-qt --without-python --disable-video --without-gtk" |
| 25 | |
| 26 | CPPFLAGS += "-Wno-error" |
| 27 | |
| 28 | do_install_append() { |
| 29 | #remove usr/bin if empty |
| 30 | rmdir ${D}${bindir} |
| 31 | } |