Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 1 | DESCRIPTION = "A small image for testing meta-security packages" |
| 2 | |
| 3 | IMAGE_FEATURES += "ssh-server-openssh" |
| 4 | |
| 5 | TEST_SUITES = "ssh ping ptest apparmor clamav samhain sssd tripwire checksec smack suricata" |
| 6 | |
| 7 | INSTALL_CLAMAV_CVD = "1" |
| 8 | |
| 9 | IMAGE_INSTALL = "\ |
| 10 | packagegroup-base \ |
| 11 | packagegroup-core-boot \ |
| 12 | packagegroup-core-security-ptest \ |
| 13 | clamav \ |
| 14 | tripwire \ |
| 15 | checksec \ |
| 16 | suricata \ |
| 17 | samhain-standalone \ |
| 18 | ${@bb.utils.contains("DISTRO_FEATURES", "pam", "sssd", "",d)} \ |
| 19 | ${@bb.utils.contains("DISTRO_FEATURES", "apparmor", "apparmor", "",d)} \ |
| 20 | ${@bb.utils.contains("DISTRO_FEATURES", "smack", "smack-test", "",d)} \ |
| 21 | os-release \ |
| 22 | " |
| 23 | |
| 24 | |
| 25 | IMAGE_LINGUAS ?= " " |
| 26 | |
| 27 | LICENSE = "MIT" |
| 28 | |
| 29 | inherit core-image |
| 30 | |
| 31 | export IMAGE_BASENAME = "security-test-image" |
| 32 | |
| 33 | IMAGE_ROOTFS_EXTRA_SPACE = "5242880" |