Brad Bishop | eb610d6 | 2019-09-09 14:57:03 -0400 | [diff] [blame] | 1 | require recipes-devtools/qemu/qemu.inc |
Brad Bishop | 754b8fa | 2019-08-20 09:16:20 -0400 | [diff] [blame] | 2 | require qemu-xilinx.inc |
| 3 | |
Brad Bishop | eb610d6 | 2019-09-09 14:57:03 -0400 | [diff] [blame] | 4 | BBCLASSEXTEND = "nativesdk" |
| 5 | |
| 6 | RDEPENDS_${PN}_class-target += "bash" |
| 7 | |
| 8 | EXTRA_OECONF_append_class-target = " --target-list=${@get_qemu_target_list(d)}" |
| 9 | EXTRA_OECONF_append_class-nativesdk = " --target-list=${@get_qemu_target_list(d)}" |
| 10 | |
| 11 | do_install_append_class-nativesdk() { |
| 12 | ${@bb.utils.contains('PACKAGECONFIG', 'gtk+', 'make_qemu_wrapper', '', d)} |
| 13 | } |