Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "GStreamer examples (including gtk-play, gst-play)" |
| 2 | DESCRIPTION = "GStreamer example applications" |
| 3 | HOMEPAGE = "https://gitlab.freedesktop.org/gstreamer/gst-examples" |
| 4 | BUGTRACKER = "https://gitlab.freedesktop.org/gstreamer/gst-examples/-/issues" |
| 5 | LICENSE = "LGPL-2.0+" |
| 6 | LIC_FILES_CHKSUM = "file://playback/player/gtk/gtk-play.c;beginline=1;endline=20;md5=f8c72dae3d36823ec716a9ebcae593b9" |
| 7 | |
| 8 | DEPENDS = "glib-2.0 gstreamer1.0 gstreamer1.0-plugins-base gstreamer1.0-plugins-bad gtk+3 libsoup-2.4 json-glib glib-2.0-native" |
| 9 | |
| 10 | SRC_URI = "git://gitlab.freedesktop.org/gstreamer/gst-examples.git;protocol=https;branch=1.18 \ |
| 11 | file://0001-Make-player-examples-installable.patch \ |
| 12 | file://gst-player.desktop \ |
| 13 | " |
| 14 | |
| 15 | SRCREV = "fe9a365dc0f1ff632abcfe3322ac5527a2cf30a0" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit meson pkgconfig features_check |
| 20 | |
| 21 | UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)" |
| 22 | |
| 23 | ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}" |
| 24 | |
| 25 | do_install:append() { |
| 26 | install -m 0644 -D ${WORKDIR}/gst-player.desktop ${D}${datadir}/applications/gst-player.desktop |
| 27 | } |
| 28 | |
| 29 | RDEPENDS:${PN} = "gstreamer1.0-plugins-base-playback" |
| 30 | RRECOMMENDS:${PN} = "gstreamer1.0-plugins-base-meta \ |
| 31 | gstreamer1.0-plugins-good-meta \ |
| 32 | gstreamer1.0-plugins-bad-meta \ |
| 33 | ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-libav", "", d)} \ |
| 34 | ${@bb.utils.contains("LICENSE_FLAGS_WHITELIST", "commercial", "gstreamer1.0-plugins-ugly-meta", "", d)}" |
| 35 | RPROVIDES:${PN} += "gst-player gst-player-bin" |