Thang Q. Nguyen | 7d0f84a | 2021-09-23 06:47:52 +0000 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Mt.Jade Platform Init Service" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Mt.Jade Platform Init Daemon" |
| 3 | |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 7 | |
| 8 | inherit systemd |
| 9 | inherit obmc-phosphor-systemd |
| 10 | |
| 11 | DEPENDS += "systemd" |
| 12 | RDEPENDS:${PN} += "libsystemd" |
| 13 | RDEPENDS:${PN} += "bash" |
| 14 | |
| 15 | SRC_URI = " \ |
| 16 | file://ampere_platform_init.sh \ |
Chau Ly | 0a0f348 | 2023-04-13 05:06:28 +0000 | [diff] [blame] | 17 | file://ampere_uart_console_setup.sh \ |
Thu Nguyen | e50b26f | 2023-07-12 11:59:14 +0700 | [diff] [blame^] | 18 | file://mtjade_platform_gpios_init.sh \ |
Chau Ly | 0a0f348 | 2023-04-13 05:06:28 +0000 | [diff] [blame] | 19 | file://ampere_uartmux_ctrl.sh \ |
Thang Q. Nguyen | 7d0f84a | 2021-09-23 06:47:52 +0000 | [diff] [blame] | 20 | file://ampere-platform-init.service \ |
| 21 | " |
| 22 | |
| 23 | SYSTEMD_PACKAGES = "${PN}" |
| 24 | SYSTEMD_SERVICE:${PN} = "ampere-platform-init.service" |
| 25 | |
| 26 | do_install () { |
| 27 | install -d ${D}${sbindir} |
| 28 | install -m 0755 ${WORKDIR}/ampere_platform_init.sh ${D}${sbindir}/ |
Chau Ly | 0a0f348 | 2023-04-13 05:06:28 +0000 | [diff] [blame] | 29 | install -m 0755 ${WORKDIR}/ampere_uart_console_setup.sh ${D}${sbindir}/ |
| 30 | install -m 0755 ${WORKDIR}/ampere_uartmux_ctrl.sh ${D}/${sbindir}/ |
Thang Q. Nguyen | 7d0f84a | 2021-09-23 06:47:52 +0000 | [diff] [blame] | 31 | install -d ${D}${systemd_unitdir}/system/ |
| 32 | install -m 0644 ${WORKDIR}/ampere-platform-init.service ${D}${systemd_unitdir}/system |
Thu Nguyen | e50b26f | 2023-07-12 11:59:14 +0700 | [diff] [blame^] | 33 | install -m 0755 ${WORKDIR}/mtjade_platform_gpios_init.sh ${D}${sbindir}/platform_gpios_init.sh |
Thang Q. Nguyen | 7d0f84a | 2021-09-23 06:47:52 +0000 | [diff] [blame] | 34 | } |