Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 1 | # Copyright (C) 2021 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = "``aspectlib`` is an aspect-oriented programming, monkey-patch and decorators library. It is useful when changing" |
| 5 | HOMEPAGE = "https://github.com/ionelmc/python-aspectlib" |
| 6 | LICENSE = "BSD-2-Clause" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d58b3f20fd10347a9458b8a03793b62e" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "d275ec82c4c2712e564bb760e4accff8f061f648e38774feabeb8b241cf3a4aa" |
| 10 | |
| 11 | inherit ptest pypi setuptools3 |
| 12 | |
| 13 | SRC_URI += "file://run-ptest \ |
| 14 | file://0001-Remove-tornado-6-test-constraint.-Ref-15.patch \ |
| 15 | " |
| 16 | |
| 17 | do_install_ptest() { |
| 18 | install -d ${D}${PTEST_PATH}/tests |
| 19 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 20 | } |
| 21 | |
| 22 | RDEPENDS_${PN}-ptest += "\ |
| 23 | python3-tornado \ |
| 24 | python3-process-tests \ |
| 25 | " |
| 26 | |
| 27 | RDEPENDS_${PN} += "python3-core python3-fields" |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |