blob: bb9e50e1e09748f0a10c9293c25cf8b4940794a8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Backup, restore, import, and export panel layouts"
2SECTION = "x11/application"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
Andrew Geissler72956ed2021-01-08 16:11:14 -06006inherit python3native gettext gtk-icon-cache features_check
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8REQUIRED_DISTRO_FEATURES = "x11"
9
10DEPENDS += "intltool-native"
11
12SRC_URI = "http://archive.xfce.org/src/apps/${BPN}/1.0/${BP}.tar.bz2 \
13 file://not-create-link-to-locale.patch \
14 "
Andrew Geissler32b11992021-03-31 13:37:05 -050015SRC_URI[sha256sum] = "bc387c13f94109422dc72b0fcb919b0dc11619ba589d03e492252b0d2513b170"
Andrew Geissler82c905d2020-04-13 13:39:40 -050016
17do_configure() {
18 # special configure - no autotools...
19 ./configure --prefix=${prefix}
20}
21
22do_install() {
23 oe_runmake 'DESTDIR=${D}' install
24 sed -i 's:${PYTHON}:python3:g' ${D}${bindir}/xfce4-panel-profiles
25}
26
27FILES_${PN} += "${datadir}/metainfo"
28
29RDEPENDS_${PN} += "python3-pygobject python3-pexpect"