Andrew Geissler | 6ce62a2 | 2020-11-30 19:58:47 -0600 | [diff] [blame] | 1 | SUMMARY = "Library for building powerful interactive command lines in Python" |
| 2 | DESCRIPTION = "Measures the displayed width of unicode strings in a terminal" |
| 3 | HOMEPAGE = "https://github.com/jquast/wcwidth" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b15979c39a2543892fca8cd86b4b52cb" |
| 6 | |
| 7 | SRC_URI[md5sum] = "a07a75f99d316e14838ac760c831ea37" |
| 8 | SRC_URI[sha256sum] = "c4d647b99872929fdb7bdcaa4fbe7f01413ed3d98077df798530e5b04f116c83" |
| 9 | |
| 10 | inherit pypi setuptools3 ptest |
| 11 | |
| 12 | SRC_URI += " \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | RDEPENDS_${PN}-ptest += " \ |
| 17 | ${PYTHON_PN}-pytest \ |
| 18 | " |
| 19 | |
| 20 | do_install_ptest() { |
| 21 | install -d ${D}${PTEST_PATH}/tests |
| 22 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 23 | } |
| 24 | |
| 25 | BBCLASSEXTEND = "native nativesdk" |