Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 1 | # Copyright (C) 2012 Linux Foundation |
| 2 | # Author: Richard Purdie |
| 3 | # Some code and influence taken from srctree.bbclass: |
| 4 | # Copyright (C) 2009 Chris Larson <clarson@kergoth.com> |
| 5 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 6 | # |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 7 | # externalsrc.bbclass enables use of an existing source tree, usually external to |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 8 | # the build system to build a piece of software rather than the usual fetch/unpack/patch |
| 9 | # process. |
| 10 | # |
| 11 | # To use, add externalsrc to the global inherit and set EXTERNALSRC to point at the |
| 12 | # directory you want to use containing the sources e.g. from local.conf for a recipe |
| 13 | # called "myrecipe" you would do: |
| 14 | # |
| 15 | # INHERIT += "externalsrc" |
| 16 | # EXTERNALSRC_pn-myrecipe = "/path/to/my/source/tree" |
| 17 | # |
| 18 | # In order to make this class work for both target and native versions (or with |
| 19 | # multilibs/cross or other BBCLASSEXTEND variants), B is set to point to a separate |
| 20 | # directory under the work directory (split source and build directories). This is |
| 21 | # the default, but the build directory can be set to the source directory if |
| 22 | # circumstances dictate by setting EXTERNALSRC_BUILD to the same value, e.g.: |
| 23 | # |
| 24 | # EXTERNALSRC_BUILD_pn-myrecipe = "/path/to/my/source/tree" |
| 25 | # |
| 26 | |
| 27 | SRCTREECOVEREDTASKS ?= "do_patch do_unpack do_fetch" |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 28 | EXTERNALSRC_SYMLINKS ?= "oe-workdir:${WORKDIR} oe-logs:${T}" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 29 | |
| 30 | python () { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 31 | externalsrc = d.getVar('EXTERNALSRC') |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 32 | externalsrcbuild = d.getVar('EXTERNALSRC_BUILD') |
| 33 | |
| 34 | if externalsrc and not externalsrc.startswith("/"): |
| 35 | bb.error("EXTERNALSRC must be an absolute path") |
| 36 | if externalsrcbuild and not externalsrcbuild.startswith("/"): |
| 37 | bb.error("EXTERNALSRC_BUILD must be an absolute path") |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 38 | |
| 39 | # If this is the base recipe and EXTERNALSRC is set for it or any of its |
| 40 | # derivatives, then enable BB_DONT_CACHE to force the recipe to always be |
| 41 | # re-parsed so that the file-checksums function for do_compile is run every |
| 42 | # time. |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 43 | bpn = d.getVar('BPN') |
Brad Bishop | 004d499 | 2018-10-02 23:54:45 +0200 | [diff] [blame] | 44 | classextend = (d.getVar('BBCLASSEXTEND') or '').split() |
| 45 | if bpn == d.getVar('PN') or not classextend: |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 46 | if (externalsrc or |
| 47 | ('native' in classextend and |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 48 | d.getVar('EXTERNALSRC_pn-%s-native' % bpn)) or |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 49 | ('nativesdk' in classextend and |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 50 | d.getVar('EXTERNALSRC_pn-nativesdk-%s' % bpn)) or |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 51 | ('cross' in classextend and |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 52 | d.getVar('EXTERNALSRC_pn-%s-cross' % bpn))): |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 53 | d.setVar('BB_DONT_CACHE', '1') |
| 54 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 55 | if externalsrc: |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 56 | import oe.recipeutils |
| 57 | import oe.path |
| 58 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 59 | d.setVar('S', externalsrc) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 60 | if externalsrcbuild: |
| 61 | d.setVar('B', externalsrcbuild) |
| 62 | else: |
| 63 | d.setVar('B', '${WORKDIR}/${BPN}-${PV}/') |
| 64 | |
| 65 | local_srcuri = [] |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 66 | fetch = bb.fetch2.Fetch((d.getVar('SRC_URI') or '').split(), d) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 67 | for url in fetch.urls: |
| 68 | url_data = fetch.ud[url] |
| 69 | parm = url_data.parm |
| 70 | if (url_data.type == 'file' or |
| 71 | 'type' in parm and parm['type'] == 'kmeta'): |
| 72 | local_srcuri.append(url) |
| 73 | |
| 74 | d.setVar('SRC_URI', ' '.join(local_srcuri)) |
| 75 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 76 | # Dummy value because the default function can't be called with blank SRC_URI |
| 77 | d.setVar('SRCPV', '999') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 78 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 79 | if d.getVar('CONFIGUREOPT_DEPTRACK') == '--disable-dependency-tracking': |
| 80 | d.setVar('CONFIGUREOPT_DEPTRACK', '') |
| 81 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 82 | tasks = filter(lambda k: d.getVarFlag(k, "task"), d.keys()) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 83 | |
| 84 | for task in tasks: |
| 85 | if task.endswith("_setscene"): |
| 86 | # sstate is never going to work for external source trees, disable it |
| 87 | bb.build.deltask(task, d) |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 88 | elif os.path.realpath(d.getVar('S')) == os.path.realpath(d.getVar('B')): |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 89 | # Since configure will likely touch ${S}, ensure only we lock so one task has access at a time |
| 90 | d.appendVarFlag(task, "lockfiles", " ${S}/singletask.lock") |
| 91 | |
| 92 | # We do not want our source to be wiped out, ever (kernel.bbclass does this for do_clean) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 93 | cleandirs = oe.recipeutils.split_var_value(d.getVarFlag(task, 'cleandirs', False) or '') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 94 | setvalue = False |
| 95 | for cleandir in cleandirs[:]: |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 96 | if oe.path.is_path_parent(externalsrc, d.expand(cleandir)): |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 97 | cleandirs.remove(cleandir) |
| 98 | setvalue = True |
| 99 | if setvalue: |
| 100 | d.setVarFlag(task, 'cleandirs', ' '.join(cleandirs)) |
| 101 | |
| 102 | fetch_tasks = ['do_fetch', 'do_unpack'] |
| 103 | # If we deltask do_patch, there's no dependency to ensure do_unpack gets run, so add one |
Patrick Williams | f1e5d69 | 2016-03-30 15:21:19 -0500 | [diff] [blame] | 104 | # Note that we cannot use d.appendVarFlag() here because deps is expected to be a list object, not a string |
| 105 | d.setVarFlag('do_configure', 'deps', (d.getVarFlag('do_configure', 'deps', False) or []) + ['do_unpack']) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 106 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 107 | for task in d.getVar("SRCTREECOVEREDTASKS").split(): |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 108 | if local_srcuri and task in fetch_tasks: |
| 109 | continue |
| 110 | bb.build.deltask(task, d) |
| 111 | |
| 112 | d.prependVarFlag('do_compile', 'prefuncs', "externalsrc_compile_prefunc ") |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 113 | d.prependVarFlag('do_configure', 'prefuncs', "externalsrc_configure_prefunc ") |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 114 | |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 115 | d.setVarFlag('do_compile', 'file-checksums', '${@srctree_hash_files(d)}') |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 116 | d.setVarFlag('do_configure', 'file-checksums', '${@srctree_configure_hash_files(d)}') |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 117 | |
| 118 | # We don't want the workdir to go away |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 119 | d.appendVar('RM_WORK_EXCLUDE', ' ' + d.getVar('PN')) |
| 120 | |
| 121 | bb.build.addtask('do_buildclean', |
| 122 | 'do_clean' if d.getVar('S') == d.getVar('B') else None, |
| 123 | None, d) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 124 | |
| 125 | # If B=S the same builddir is used even for different architectures. |
| 126 | # Thus, use a shared CONFIGURESTAMPFILE and STAMP directory so that |
| 127 | # change of do_configure task hash is correctly detected and stamps are |
| 128 | # invalidated if e.g. MACHINE changes. |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 129 | if d.getVar('S') == d.getVar('B'): |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 130 | configstamp = '${TMPDIR}/work-shared/${PN}/${EXTENDPE}${PV}-${PR}/configure.sstate' |
| 131 | d.setVar('CONFIGURESTAMPFILE', configstamp) |
| 132 | d.setVar('STAMP', '${STAMPS_DIR}/work-shared/${PN}/${EXTENDPE}${PV}-${PR}') |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 133 | d.setVar('STAMPCLEAN', '${STAMPS_DIR}/work-shared/${PN}/*-*') |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 134 | } |
| 135 | |
| 136 | python externalsrc_configure_prefunc() { |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 137 | s_dir = d.getVar('S') |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 138 | # Create desired symlinks |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 139 | symlinks = (d.getVar('EXTERNALSRC_SYMLINKS') or '').split() |
| 140 | newlinks = [] |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 141 | for symlink in symlinks: |
| 142 | symsplit = symlink.split(':', 1) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 143 | lnkfile = os.path.join(s_dir, symsplit[0]) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 144 | target = d.expand(symsplit[1]) |
| 145 | if len(symsplit) > 1: |
| 146 | if os.path.islink(lnkfile): |
| 147 | # Link already exists, leave it if it points to the right location already |
| 148 | if os.readlink(lnkfile) == target: |
| 149 | continue |
| 150 | os.unlink(lnkfile) |
| 151 | elif os.path.exists(lnkfile): |
| 152 | # File/dir exists with same name as link, just leave it alone |
| 153 | continue |
| 154 | os.symlink(target, lnkfile) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 155 | newlinks.append(symsplit[0]) |
| 156 | # Hide the symlinks from git |
| 157 | try: |
| 158 | git_exclude_file = os.path.join(s_dir, '.git/info/exclude') |
| 159 | if os.path.exists(git_exclude_file): |
| 160 | with open(git_exclude_file, 'r+') as efile: |
| 161 | elines = efile.readlines() |
| 162 | for link in newlinks: |
| 163 | if link in elines or '/'+link in elines: |
| 164 | continue |
| 165 | efile.write('/' + link + '\n') |
| 166 | except IOError as ioe: |
| 167 | bb.note('Failed to hide EXTERNALSRC_SYMLINKS from git') |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 168 | } |
| 169 | |
| 170 | python externalsrc_compile_prefunc() { |
| 171 | # Make it obvious that this is happening, since forgetting about it could lead to much confusion |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 172 | bb.plain('NOTE: %s: compiling from external source tree %s' % (d.getVar('PN'), d.getVar('EXTERNALSRC'))) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 173 | } |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 174 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 175 | do_buildclean[dirs] = "${S} ${B}" |
| 176 | do_buildclean[nostamp] = "1" |
| 177 | do_buildclean[doc] = "Call 'make clean' or equivalent in ${B}" |
| 178 | externalsrc_do_buildclean() { |
| 179 | if [ -e Makefile -o -e makefile -o -e GNUmakefile ]; then |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 180 | rm -f ${@' '.join([x.split(':')[0] for x in (d.getVar('EXTERNALSRC_SYMLINKS') or '').split()])} |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 181 | if [ "${CLEANBROKEN}" != "1" ]; then |
| 182 | oe_runmake clean || die "make failed" |
| 183 | fi |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 184 | else |
| 185 | bbnote "nothing to do - no makefile found" |
| 186 | fi |
| 187 | } |
| 188 | |
| 189 | def srctree_hash_files(d, srcdir=None): |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 190 | import shutil |
| 191 | import subprocess |
| 192 | import tempfile |
| 193 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 194 | s_dir = srcdir or d.getVar('EXTERNALSRC') |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 195 | git_dir = None |
| 196 | |
| 197 | try: |
| 198 | git_dir = os.path.join(s_dir, |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 199 | subprocess.check_output(['git', '-C', s_dir, 'rev-parse', '--git-dir'], stderr=subprocess.DEVNULL).decode("utf-8").rstrip()) |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 200 | except subprocess.CalledProcessError: |
| 201 | pass |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 202 | |
| 203 | ret = " " |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 204 | if git_dir is not None: |
Brad Bishop | a34c030 | 2019-09-23 22:34:48 -0400 | [diff] [blame] | 205 | oe_hash_file = os.path.join(git_dir, 'oe-devtool-tree-sha1-%s' % d.getVar('PN')) |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 206 | with tempfile.NamedTemporaryFile(prefix='oe-devtool-index') as tmp_index: |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 207 | # Clone index |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 208 | shutil.copyfile(os.path.join(git_dir, 'index'), tmp_index.name) |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 209 | # Update our custom index |
| 210 | env = os.environ.copy() |
| 211 | env['GIT_INDEX_FILE'] = tmp_index.name |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 212 | subprocess.check_output(['git', 'add', '-A', '.'], cwd=s_dir, env=env) |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 213 | sha1 = subprocess.check_output(['git', 'write-tree'], cwd=s_dir, env=env).decode("utf-8") |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 214 | with open(oe_hash_file, 'w') as fobj: |
| 215 | fobj.write(sha1) |
| 216 | ret = oe_hash_file + ':True' |
| 217 | else: |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 218 | ret = s_dir + '/*:True' |
Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 219 | return ret |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 220 | |
| 221 | def srctree_configure_hash_files(d): |
| 222 | """ |
| 223 | Get the list of files that should trigger do_configure to re-execute, |
| 224 | based on the value of CONFIGURE_FILES |
| 225 | """ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 226 | in_files = (d.getVar('CONFIGURE_FILES') or '').split() |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 227 | out_items = [] |
| 228 | search_files = [] |
| 229 | for entry in in_files: |
| 230 | if entry.startswith('/'): |
| 231 | out_items.append('%s:%s' % (entry, os.path.exists(entry))) |
| 232 | else: |
| 233 | search_files.append(entry) |
| 234 | if search_files: |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 235 | s_dir = d.getVar('EXTERNALSRC') |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 236 | for root, _, files in os.walk(s_dir): |
| 237 | for f in files: |
| 238 | if f in search_files: |
| 239 | out_items.append('%s:True' % os.path.join(root, f)) |
| 240 | return ' '.join(out_items) |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 241 | |
| 242 | EXPORT_FUNCTIONS do_buildclean |