Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 1 | # Handle Go Modules support |
| 2 | # |
| 3 | # When using Go Modules, the the current working directory MUST be at or below |
| 4 | # the location of the 'go.mod' file when the go tool is used, and there is no |
| 5 | # way to tell it to look elsewhere. It will automatically look upwards for the |
| 6 | # file, but not downwards. |
| 7 | # |
| 8 | # To support this use case, we provide the `GO_WORKDIR` variable, which defaults |
| 9 | # to `GO_IMPORT` but allows for easy override. |
| 10 | # |
| 11 | # Copyright 2020 (C) O.S. Systems Software LTDA. |
| 12 | |
| 13 | # The '-modcacherw' option ensures we have write access to the cached objects so |
| 14 | # we avoid errors during clean task as well as when removing the TMPDIR. |
Andrew Geissler | c3d88e4 | 2020-10-02 09:45:00 -0500 | [diff] [blame] | 15 | GOBUILDFLAGS_append = " -modcacherw" |
Andrew Geissler | 1e34c2d | 2020-05-29 16:02:59 -0500 | [diff] [blame] | 16 | |
| 17 | inherit go |
| 18 | |
| 19 | GO_WORKDIR ?= "${GO_IMPORT}" |
| 20 | do_compile[dirs] += "${B}/src/${GO_WORKDIR}" |