Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | # reproducible_build.bbclass |
| 2 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 3 | # Sets SOURCE_DATE_EPOCH in each component's build environment. |
| 4 | # Upstream components (generally) respect this environment variable, |
| 5 | # using it in place of the "current" date and time. |
| 6 | # See https://reproducible-builds.org/specs/source-date-epoch/ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 7 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 8 | # After sources are unpacked but before they are patched, we set a reproducible value for SOURCE_DATE_EPOCH. |
| 9 | # This value should be reproducible for anyone who builds the same revision from the same sources. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 10 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 11 | # There are 4 ways we determine SOURCE_DATE_EPOCH: |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 12 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 13 | # 1. Use the value from __source_date_epoch.txt file if this file exists. |
| 14 | # This file was most likely created in the previous build by one of the following methods 2,3,4. |
| 15 | # Alternatively, it can be provided by a recipe via SRC_URI. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | # If the file does not exist: |
| 18 | # |
| 19 | # 2. If there is a git checkout, use the last git commit timestamp. |
| 20 | # Git does not preserve file timestamps on checkout. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 21 | # |
| 22 | # 3. Use the mtime of "known" files such as NEWS, CHANGLELOG, ... |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 23 | # This works for well-kept repositories distributed via tarball. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 24 | # |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 25 | # 4. Use the modification time of the youngest file in the source tree, if there is one. |
| 26 | # This will be the newest file from the distribution tarball, if any. |
| 27 | # |
| 28 | # 5. Fall back to a fixed timestamp. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 29 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 30 | # Once the value of SOURCE_DATE_EPOCH is determined, it is stored in the recipe's SDE_FILE. |
| 31 | # If none of these mechanisms are suitable, replace the do_deploy_source_date_epoch task |
| 32 | # with recipe-specific functionality to write the appropriate SOURCE_DATE_EPOCH into the SDE_FILE. |
| 33 | # |
| 34 | # If this file is found by other tasks, the value is exported in the SOURCE_DATE_EPOCH variable. |
| 35 | # SOURCE_DATE_EPOCH is set for all tasks that might use it (do_configure, do_compile, do_package, ...) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 36 | |
| 37 | BUILD_REPRODUCIBLE_BINARIES ??= '1' |
| 38 | inherit ${@oe.utils.ifelse(d.getVar('BUILD_REPRODUCIBLE_BINARIES') == '1', 'reproducible_build_simple', '')} |
| 39 | |
| 40 | SDE_DIR ="${WORKDIR}/source-date-epoch" |
| 41 | SDE_FILE = "${SDE_DIR}/__source_date_epoch.txt" |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 42 | SDE_DEPLOYDIR = "${WORKDIR}/deploy-source-date-epoch" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 43 | |
| 44 | SSTATETASKS += "do_deploy_source_date_epoch" |
| 45 | |
| 46 | do_deploy_source_date_epoch () { |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 47 | mkdir -p ${SDE_DEPLOYDIR} |
| 48 | if [ -e ${SDE_FILE} ]; then |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 49 | echo "Deploying SDE from ${SDE_FILE} -> ${SDE_DEPLOYDIR}." |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 50 | cp -p ${SDE_FILE} ${SDE_DEPLOYDIR}/__source_date_epoch.txt |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 51 | else |
| 52 | echo "${SDE_FILE} not found!" |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 53 | fi |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 54 | } |
| 55 | |
| 56 | python do_deploy_source_date_epoch_setscene () { |
| 57 | sstate_setscene(d) |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 58 | bb.utils.mkdirhier(d.getVar('SDE_DIR')) |
| 59 | sde_file = os.path.join(d.getVar('SDE_DEPLOYDIR'), '__source_date_epoch.txt') |
| 60 | if os.path.exists(sde_file): |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 61 | target = d.getVar('SDE_FILE') |
| 62 | bb.debug(1, "Moving setscene SDE file %s -> %s" % (sde_file, target)) |
| 63 | os.rename(sde_file, target) |
| 64 | else: |
| 65 | bb.debug(1, "%s not found!" % sde_file) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 66 | } |
| 67 | |
Brad Bishop | 00e122a | 2019-10-05 11:10:57 -0400 | [diff] [blame] | 68 | do_deploy_source_date_epoch[dirs] = "${SDE_DEPLOYDIR}" |
| 69 | do_deploy_source_date_epoch[sstate-plaindirs] = "${SDE_DEPLOYDIR}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 70 | addtask do_deploy_source_date_epoch_setscene |
| 71 | addtask do_deploy_source_date_epoch before do_configure after do_patch |
| 72 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 73 | python create_source_date_epoch_stamp() { |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 74 | import oe.reproducible |
| 75 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 76 | epochfile = d.getVar('SDE_FILE') |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 77 | # If it exists we need to regenerate as the sources may have changed |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 78 | if os.path.isfile(epochfile): |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 79 | bb.debug(1, "Deleting existing SOURCE_DATE_EPOCH from: %s" % epochfile) |
| 80 | os.remove(epochfile) |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 81 | |
Andrew Geissler | b7d2861 | 2020-07-24 16:15:54 -0500 | [diff] [blame] | 82 | source_date_epoch = oe.reproducible.get_source_date_epoch(d, d.getVar('S')) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 83 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 84 | bb.debug(1, "SOURCE_DATE_EPOCH: %d" % source_date_epoch) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 85 | bb.utils.mkdirhier(d.getVar('SDE_DIR')) |
| 86 | with open(epochfile, 'w') as f: |
| 87 | f.write(str(source_date_epoch)) |
| 88 | } |
| 89 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 90 | def get_source_date_epoch_value(d): |
| 91 | cached = d.getVar('__CACHED_SOURCE_DATE_EPOCH') |
| 92 | if cached: |
| 93 | return cached |
| 94 | |
| 95 | epochfile = d.getVar('SDE_FILE') |
| 96 | source_date_epoch = 0 |
| 97 | if os.path.isfile(epochfile): |
| 98 | with open(epochfile, 'r') as f: |
| 99 | s = f.read() |
| 100 | try: |
| 101 | source_date_epoch = int(s) |
| 102 | except ValueError: |
| 103 | bb.warn("SOURCE_DATE_EPOCH value '%s' is invalid. Reverting to 0" % s) |
| 104 | source_date_epoch = 0 |
| 105 | bb.debug(1, "SOURCE_DATE_EPOCH: %d" % source_date_epoch) |
| 106 | else: |
| 107 | bb.debug(1, "Cannot find %s. SOURCE_DATE_EPOCH will default to %d" % (epochfile, source_date_epoch)) |
| 108 | |
| 109 | d.setVar('__CACHED_SOURCE_DATE_EPOCH', str(source_date_epoch)) |
| 110 | return str(source_date_epoch) |
| 111 | |
| 112 | export SOURCE_DATE_EPOCH ?= "${@get_source_date_epoch_value(d)}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 113 | BB_HASHBASE_WHITELIST += "SOURCE_DATE_EPOCH" |
| 114 | |
| 115 | python () { |
| 116 | if d.getVar('BUILD_REPRODUCIBLE_BINARIES') == '1': |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 117 | d.appendVarFlag("do_unpack", "postfuncs", " create_source_date_epoch_stamp") |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 118 | } |