Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | # avoids build breaks when using no-static-libs.inc |
| 2 | DISABLE_STATIC = "" |
| 3 | |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 4 | # What Python interpretter to use. Defaults to Python 3 but can be |
| 5 | # overridden if required. |
| 6 | WAF_PYTHON ?= "python3" |
| 7 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | B = "${WORKDIR}/build" |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 9 | do_configure[cleandirs] += "${B}" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 10 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 11 | EXTRA_OECONF_append = " ${PACKAGECONFIG_CONFARGS}" |
| 12 | |
Andrew Geissler | f034379 | 2020-11-18 10:42:21 -0600 | [diff] [blame] | 13 | EXTRA_OEWAF_BUILD ??= "" |
| 14 | # In most cases, you want to pass the same arguments to `waf build` and `waf |
| 15 | # install`, but you can override it if necessary |
| 16 | EXTRA_OEWAF_INSTALL ??= "${EXTRA_OEWAF_BUILD}" |
| 17 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 18 | def waflock_hash(d): |
| 19 | # Calculates the hash used for the waf lock file. This should include |
| 20 | # all of the user controllable inputs passed to waf configure. Note |
| 21 | # that the full paths for ${B} and ${S} are used; this is OK and desired |
| 22 | # because a change to either of these should create a unique lock file |
| 23 | # to prevent collisions. |
| 24 | import hashlib |
| 25 | h = hashlib.sha512() |
| 26 | def update(name): |
| 27 | val = d.getVar(name) |
| 28 | if val is not None: |
| 29 | h.update(val.encode('utf-8')) |
| 30 | update('S') |
| 31 | update('B') |
| 32 | update('prefix') |
| 33 | update('EXTRA_OECONF') |
| 34 | return h.hexdigest() |
| 35 | |
| 36 | # Use WAFLOCK to specify a separate lock file. The build is already |
| 37 | # sufficiently isolated by setting the output directory, this ensures that |
| 38 | # bitbake won't step on toes of any other configured context in the source |
| 39 | # directory (e.g. if the source is coming from externalsrc and was previously |
| 40 | # configured elsewhere). |
| 41 | export WAFLOCK = ".lock-waf_oe_${@waflock_hash(d)}_build" |
| 42 | BB_HASHBASE_WHITELIST += "WAFLOCK" |
| 43 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 44 | python waf_preconfigure() { |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 45 | import subprocess |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 46 | from distutils.version import StrictVersion |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 47 | subsrcdir = d.getVar('S') |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 48 | python = d.getVar('WAF_PYTHON') |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 49 | wafbin = os.path.join(subsrcdir, 'waf') |
| 50 | try: |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 51 | result = subprocess.check_output([python, wafbin, '--version'], cwd=subsrcdir, stderr=subprocess.STDOUT) |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 52 | version = result.decode('utf-8').split()[1] |
| 53 | if StrictVersion(version) >= StrictVersion("1.8.7"): |
| 54 | d.setVar("WAF_EXTRA_CONF", "--bindir=${bindir} --libdir=${libdir}") |
| 55 | except subprocess.CalledProcessError as e: |
| 56 | bb.warn("Unable to execute waf --version, exit code %d. Assuming waf version without bindir/libdir support." % e.returncode) |
| 57 | except FileNotFoundError: |
| 58 | bb.fatal("waf does not exist in %s" % subsrcdir) |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 59 | } |
| 60 | |
| 61 | do_configure[prefuncs] += "waf_preconfigure" |
| 62 | |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 63 | waf_do_configure() { |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 64 | (cd ${S} && ${WAF_PYTHON} ./waf configure -o ${B} --prefix=${prefix} ${WAF_EXTRA_CONF} ${EXTRA_OECONF}) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 65 | } |
| 66 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 67 | do_compile[progress] = "outof:^\[\s*(\d+)/\s*(\d+)\]\s+" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 68 | waf_do_compile() { |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 69 | (cd ${S} && ${WAF_PYTHON} ./waf build ${@oe.utils.parallel_make_argument(d, '-j%d', limit=64)} ${EXTRA_OEWAF_BUILD}) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 70 | } |
| 71 | |
| 72 | waf_do_install() { |
Andrew Geissler | 4c19ea1 | 2020-10-27 13:52:24 -0500 | [diff] [blame] | 73 | (cd ${S} && ${WAF_PYTHON} ./waf install --destdir=${D} ${EXTRA_OEWAF_INSTALL}) |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 74 | } |
| 75 | |
| 76 | EXPORT_FUNCTIONS do_configure do_compile do_install |