Matt Spinler | b45c182 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 1 | SUMMARY = "IBM DBus Interfaces" |
| 2 | DESCRIPTION = "Generated bindings, using sdbus++, for the IBM YAML" |
| 3 | PR = "r1" |
Patrick Venture | 56e154e | 2018-10-17 15:10:55 -0700 | [diff] [blame] | 4 | PV = "1.0+git${SRCPV}" |
Patrick Venture | c484d32 | 2018-11-03 08:36:39 -0700 | [diff] [blame] | 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
Matt Spinler | b45c182 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit autotools pkgconfig |
Patrick Williams | 5c8a528 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 11 | inherit python3native |
Matt Spinler | b45c182 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 12 | inherit phosphor-dbus-yaml |
| 13 | |
| 14 | DEPENDS += "autoconf-archive-native" |
Patrick Williams | 5c8a528 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 15 | DEPENDS += "${PYTHON_PN}-sdbus++-native" |
Matt Spinler | b45c182 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 16 | |
| 17 | SRC_URI += "git://github.com/openbmc/ibm-dbus-interfaces" |
Andrew Geissler | d9ad69f | 2019-02-21 21:50:37 +0000 | [diff] [blame] | 18 | SRCREV = "109271bb4de159b9cf13c56acded3eb79bff61fb" |
Matt Spinler | b45c182 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 19 | |
Matt Spinler | b45c182 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 20 | PACKAGECONFIG ??= "libibm_dbus" |
| 21 | PACKAGECONFIG[libibm_dbus] = " \ |
| 22 | --enable-libibm_dbus, \ |
| 23 | --disable-libibm_dbus, \ |
| 24 | systemd sdbusplus, \ |
Patrick Williams | 5c8a528 | 2020-03-31 16:43:15 -0500 | [diff] [blame] | 25 | libsystemd \ |
Matt Spinler | b45c182 | 2018-03-26 16:23:38 -0500 | [diff] [blame] | 26 | " |
| 27 | |
| 28 | PACKAGECONFIG_remove_class-native = "libibm_dbus" |
| 29 | PACKAGECONFIG_remove_class-nativesdk = "libibm_dbus" |
| 30 | |
| 31 | BBCLASSEXTEND += "native nativesdk" |