Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "A library for bits of crypto UI and parsing etc" |
| 2 | DESCRIPTION = "GCR is a library for displaying certificates, and crypto UI, \ |
| 3 | accessing key stores. It also provides the viewer for crypto files on the \ |
| 4 | GNOME desktop." |
| 5 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/gcr" |
| 6 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/gcr/issues" |
| 7 | |
| 8 | LICENSE = "GPL-2.0-only" |
| 9 | LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605" |
| 10 | |
| 11 | DEPENDS = "p11-kit glib-2.0 libgcrypt gnupg-native \ |
| 12 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}" |
| 13 | |
| 14 | CACHED_CONFIGUREVARS += "ac_cv_path_GPG='gpg2'" |
| 15 | |
| 16 | CFLAGS += "-D_GNU_SOURCE" |
| 17 | |
| 18 | GNOMEBASEBUILDCLASS = "meson" |
| 19 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 20 | inherit gnomebase gtk-icon-cache gi-docgen features_check upstream-version-is-even vala gobject-introspection gettext mime mime-xdg |
| 21 | UPSTREAM_CHECK_REGEX = "gcr-(?P<pver>\d+\.(\d*[02468])+(\.\d+)+)\.tar.xz" |
| 22 | |
| 23 | REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'opengl', '', d)}" |
| 24 | |
| 25 | SRC_URI += "file://0001-meson.build-correctly-handle-disabled-ssh_agent-opti.patch" |
| 26 | SRC_URI[archive.sha256sum] = "c45855924f0ee7bab43e2dd38bfafd2ac815c6e9864341c0161e171173dcec7c" |
| 27 | |
| 28 | PACKAGECONFIG ??= " \ |
| 29 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 30 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'gtk', '', d)} \ |
| 31 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'gtk', '', d)} \ |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 32 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'vapi', '', d)} \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 33 | " |
| 34 | PACKAGECONFIG[gtk] = "-Dgtk4=true,-Dgtk4=false,gtk4" |
| 35 | PACKAGECONFIG[ssh_agent] = "-Dssh_agent=true,-Dssh_agent=false,libsecret,openssh" |
| 36 | #'Use systemd socket activation for server programs' |
| 37 | PACKAGECONFIG[systemd] = "-Dsystemd=enabled,-Dsystemd=disabled,systemd" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 38 | PACKAGECONFIG[vapi] = "-Dvapi=true,-Dvapi=false," |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 39 | |
| 40 | FILES:${PN} += " \ |
| 41 | ${datadir}/dbus-1 \ |
| 42 | ${datadir}/gcr-4 \ |
| 43 | ${systemd_user_unitdir}/gcr-ssh-agent.socket \ |
| 44 | ${systemd_user_unitdir}/gcr-ssh-agent.service \ |
| 45 | " |
| 46 | |
| 47 | # http://errors.yoctoproject.org/Errors/Details/20229/ |
| 48 | ARM_INSTRUCTION_SET:armv4 = "arm" |
| 49 | ARM_INSTRUCTION_SET:armv5 = "arm" |
| 50 | ARM_INSTRUCTION_SET:armv6 = "arm" |
| 51 | |
| 52 | EXTRA_OEMESON += "--cross-file=${WORKDIR}/meson-${PN}.cross" |
| 53 | |
| 54 | do_write_config:append() { |
| 55 | cat >${WORKDIR}/meson-${PN}.cross <<EOF |
| 56 | [binaries] |
| 57 | gpg2 = '${bindir}/gpg2' |
| 58 | ssh-add = '${bindir}/ssh-add' |
| 59 | ssh-agent = '${bindir}/ssh-agent' |
| 60 | EOF |
| 61 | } |