Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 1 | SUMMARY = "Keyboard configuration database for X Window" |
| 2 | |
| 3 | DESCRIPTION = "The non-arch keyboard configuration database for X \ |
| 4 | Window. The goal is to provide the consistent, well-structured, \ |
| 5 | frequently released open source of X keyboard configuration data for X \ |
| 6 | Window System implementations. The project is targeted to XKB-based \ |
| 7 | systems." |
| 8 | |
| 9 | HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig" |
| 10 | BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config" |
| 11 | |
| 12 | LICENSE = "MIT & MIT" |
| 13 | LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9" |
| 14 | |
| 15 | SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.xz" |
Andrew Geissler | 6aa7eec | 2023-03-03 12:41:14 -0600 | [diff] [blame] | 16 | SRC_URI[sha256sum] = "0690a91bab86b18868f3eee6d41e9ec4ce6894f655443d490a2184bfac56c872" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 17 | |
| 18 | SECTION = "x11/libs" |
| 19 | DEPENDS = "util-macros libxslt-native" |
| 20 | |
| 21 | EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps" |
| 22 | |
| 23 | FILES:${PN} += "${datadir}/X11/xkb" |
| 24 | |
| 25 | inherit meson pkgconfig gettext python3native |
| 26 | |
| 27 | do_install:append () { |
| 28 | install -d ${D}${datadir}/X11/xkb/compiled |
| 29 | cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg |
| 30 | } |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 31 | |
| 32 | BBCLASSEXTEND += "native" |