blob: 53dfe1634a9689e0f1e13c96792a0bc4aa4f4d7d [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Keyboard configuration database for X Window"
2
3DESCRIPTION = "The non-arch keyboard configuration database for X \
4Window. The goal is to provide the consistent, well-structured, \
5frequently released open source of X keyboard configuration data for X \
6Window System implementations. The project is targeted to XKB-based \
7systems."
8
9HOMEPAGE = "http://freedesktop.org/wiki/Software/XKeyboardConfig"
10BUGTRACKER = "https://bugs.freedesktop.org/enter_bug.cgi?product=xkeyboard-config"
11
12LICENSE = "MIT & MIT"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0e7f21ca7db975c63467d2e7624a12f9"
14
15SRC_URI = "${XORG_MIRROR}/individual/data/xkeyboard-config/${BPN}-${PV}.tar.xz"
Andrew Geissler6aa7eec2023-03-03 12:41:14 -060016SRC_URI[sha256sum] = "0690a91bab86b18868f3eee6d41e9ec4ce6894f655443d490a2184bfac56c872"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000017
18SECTION = "x11/libs"
19DEPENDS = "util-macros libxslt-native"
20
21EXTRA_OECONF = "--with-xkb-rules-symlink=xorg --disable-runtime-deps"
22
23FILES:${PN} += "${datadir}/X11/xkb"
24
25inherit meson pkgconfig gettext python3native
26
27do_install:append () {
28 install -d ${D}${datadir}/X11/xkb/compiled
29 cd ${D}${datadir}/X11/xkb/rules && ln -sf base xorg
30}
Andrew Geissler517393d2023-01-13 08:55:19 -060031
32BBCLASSEXTEND += "native"