Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "A library on top of GStreamer for building an RTSP server" |
| 2 | HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-rtsp-server/" |
| 3 | SECTION = "multimedia" |
| 4 | LICENSE = "LGPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d" |
| 6 | |
| 7 | DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base" |
| 8 | |
| 9 | PNREAL = "gst-rtsp-server" |
| 10 | |
| 11 | SRC_URI = "http://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz \ |
| 12 | file://0001-Don-t-hardcode-libtool-name-when-using-introspection.patch \ |
| 13 | file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \ |
| 14 | file://gtk-doc-tweaks.patch \ |
| 15 | " |
| 16 | |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 17 | SRC_URI[md5sum] = "ab0fb5c829266a500e14b46b7bdf06bf" |
| 18 | SRC_URI[sha256sum] = "3d0ece2afdcd601c175ece24e32a30bc19247b454f4eafd3deeec2533c6884f1" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 19 | |
| 20 | S = "${WORKDIR}/${PNREAL}-${PV}" |
| 21 | |
| 22 | inherit autotools pkgconfig upstream-version-is-even gobject-introspection gtk-doc |
| 23 | |
| 24 | EXTRA_OECONF = "--disable-examples --disable-tests" |
| 25 | |
| 26 | # Starting with 1.8.0 gst-rtsp-server includes dependency-less plugins as well |
| 27 | LIBV = "1.0" |
| 28 | require gst-plugins-package.inc |
| 29 | |
| 30 | delete_pkg_m4_file() { |
| 31 | # This m4 file is out of date and is missing PKG_CONFIG_SYSROOT_PATH tweaks which we need for introspection |
| 32 | rm "${S}/common/m4/pkg.m4" || true |
| 33 | } |
| 34 | |
| 35 | do_configure[prefuncs] += " delete_pkg_m4_file" |