Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | DESCRIPTION = "flashrom is a utility for identifying, reading, writing, verifying and erasing flash chips" |
| 2 | LICENSE = "GPL-2.0-or-later" |
| 3 | HOMEPAGE = "http://flashrom.org" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe" |
| 6 | SRC_URI = "https://download.flashrom.org/releases/flashrom-v${PV}.tar.bz2 \ |
| 7 | file://meson-fixes.patch \ |
| 8 | file://0001-flashrom-Mark-RISCV-as-non-memory-mapped-I-O-archite.patch \ |
| 9 | file://0001-hwaccess-use-__asm__-as-is-done-elsewhere.patch \ |
| 10 | " |
| 11 | SRC_URI[sha256sum] = "89a7ff5beb08c89b8795bbd253a51b9453547a864c31793302296b56bbc56d65" |
| 12 | |
| 13 | S = "${WORKDIR}/flashrom-v${PV}" |
| 14 | |
| 15 | inherit meson pkgconfig |
| 16 | |
| 17 | PACKAGECONFIG ??= "pci usb ftdi" |
| 18 | PACKAGECONFIG[pci] = "-Dpciutils=true,-Dpciutils=false,pciutils" |
| 19 | PACKAGECONFIG[usb] = "-Dusb=true,-Dusb=false,libusb" |
| 20 | PACKAGECONFIG[ftdi] = "-Dftdi=true,-Dftdi=false,libftdi" |