Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for sending desktop notifications to a notification daemon" |
| 2 | DESCRIPTION = "It sends desktop notifications to a notification daemon, as defined \ |
| 3 | in the Desktop Notifications spec. These notifications can be used to inform \ |
| 4 | the user about an event or display some form of information without getting \ |
| 5 | in the user's way." |
| 6 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/libnotify" |
| 7 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/libnotify/issues" |
| 8 | SECTION = "libs" |
| 9 | LICENSE = "LGPL-2.1-only" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 11 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 12 | DEPENDS = "glib-2.0 glib-2.0-native gdk-pixbuf" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 13 | |
| 14 | PACKAGECONFIG ?= "" |
| 15 | PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,gtk+3" |
| 16 | |
| 17 | GNOMEBASEBUILDCLASS = "meson" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 18 | GIR_MESON_ENABLE_FLAG = "enabled" |
| 19 | GIR_MESON_DISABLE_FLAG = "disabled" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 20 | inherit gnomebase gi-docgen features_check gobject-introspection |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 21 | # depends on gtk+3 if tests are enabled |
| 22 | ANY_OF_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'tests', '${GTK3DISTROFEATURES}', '', d)}" |
| 23 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 24 | SRC_URI[archive.sha256sum] = "c5f4ed3d1f86e5b118c76415aacb861873ed3e6f0c6b3181b828cf584fc5c616" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 25 | |
| 26 | EXTRA_OEMESON = "-Dman=false" |
| 27 | |
| 28 | # there were times, we had two versions of libnotify (oe-core libnotify:0.6.x / |
| 29 | # meta-gnome libnotify3: 0.7.x) |
| 30 | PROVIDES += "libnotify3" |
| 31 | RPROVIDES:${PN} += "libnotify3" |
| 32 | RCONFLICTS:${PN} += "libnotify3" |
| 33 | RREPLACES:${PN} += "libnotify3" |
| 34 | |
| 35 | # -7381 is specific to the NodeJS bindings |
Andrew Geissler | 8f84068 | 2023-07-21 09:09:43 -0500 | [diff] [blame] | 36 | CVE_STATUS[CVE-2013-7381] = "cpe-incorrect: The issue is specific to the NodeJS bindings" |