Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "GNOME session" |
| 2 | LICENSE = "GPL-2.0-only" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 4 | |
| 5 | DEPENDS = " \ |
| 6 | glib-2.0-native \ |
| 7 | libxslt-native \ |
| 8 | xmlto-native \ |
| 9 | xtrans \ |
| 10 | libice \ |
| 11 | libsm \ |
| 12 | virtual/libx11 \ |
| 13 | gtk+3 \ |
| 14 | gnome-desktop \ |
| 15 | gsettings-desktop-schemas \ |
| 16 | json-glib \ |
| 17 | " |
| 18 | |
| 19 | GNOMEBASEBUILDCLASS = "meson" |
| 20 | |
| 21 | inherit gnomebase gettext gsettings upstream-version-is-even features_check |
| 22 | |
| 23 | REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam gobject-introspection-data" |
| 24 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 25 | SRC_URI[archive.sha256sum] = "ccf829a96526135e9e9f917526515d36a5092bdfa316f3737dd8c5a524dbf2c6" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 26 | |
| 27 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', 'consolekit',d)}" |
| 28 | |
| 29 | PACKAGECONFIG[consolekit] = "-Dconsolekit=true, -Dconsolekit=false, dbus-glib" |
| 30 | PACKAGECONFIG[systemd] = "-Dsystemd=true -Dsystemd_journal=true, -Dsystemd=false -Dsystemd_journal=false, systemd" |
| 31 | |
| 32 | FILES:${PN} += " \ |
| 33 | ${datadir}/xsessions \ |
| 34 | ${datadir}/wayland-sessions \ |
| 35 | ${systemd_user_unitdir} \ |
| 36 | " |
| 37 | |
| 38 | RDEPENDS:${PN} += "gnome-shell gnome-settings-daemon gsettings-desktop-schemas" |