Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | # |
| 2 | # Copyright OpenEmbedded Contributors |
| 3 | # |
| 4 | # SPDX-License-Identifier: MIT |
| 5 | # |
| 6 | |
| 7 | DEPENDS:append:class-target = " ${PYTHON_PN}-native ${PYTHON_PN}" |
| 8 | DEPENDS:append:class-nativesdk = " ${PYTHON_PN}-native ${PYTHON_PN}" |
| 9 | RDEPENDS:${PN}:append:class-target = " ${PYTHON_PN}-core" |
| 10 | |
| 11 | export STAGING_INCDIR |
| 12 | export STAGING_LIBDIR |
| 13 | |
| 14 | # LDSHARED is the ld *command* used to create shared library |
| 15 | export LDSHARED = "${CCLD} -shared" |
| 16 | # LDXXSHARED is the ld *command* used to create shared library of C++ |
| 17 | # objects |
| 18 | export LDCXXSHARED = "${CXX} -shared" |
| 19 | # CCSHARED are the C *flags* used to create objects to go into a shared |
| 20 | # library (module) |
| 21 | export CCSHARED = "-fPIC -DPIC" |
| 22 | # LINKFORSHARED are the flags passed to the $(CC) command that links |
| 23 | # the python executable |
| 24 | export LINKFORSHARED = "${SECURITY_CFLAGS} -Xlinker -export-dynamic" |
| 25 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 26 | FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}" |
| 27 | FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a" |
| 28 | FILES:${PN}-dev += "${PYTHON_SITEPACKAGES_DIR}/*.la" |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 29 | |
Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 30 | inherit python3native python3targetconfig |