Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Library and tool for installing Python wheels" |
| 2 | DESCRIPTION = "A low-level library for installing a Python package from a wheel distribution." |
| 3 | HOMEPAGE = "https://installer.readthedocs.io/" |
| 4 | BUGTRACKER = "https://github.com/pypa/installer/issues" |
| 5 | |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=5038641aec7a77451e31da828ebfae00" |
| 8 | |
| 9 | SRC_URI += "file://interpreter.patch" |
| 10 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "a26d3e3116289bb08216e0d0f7d925fcef0b0194eedfa0c944bcaaa106c4b631" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | |
| 13 | inherit pypi python_flit_core |
| 14 | |
| 15 | # Bootstrap the native build |
Andrew Geissler | c5535c9 | 2023-01-27 16:10:19 -0600 | [diff] [blame] | 16 | DEPENDS:remove:class-native = "python3-build-native python3-installer-native" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | |
Patrick Williams | e760df8 | 2023-05-26 11:10:49 -0500 | [diff] [blame^] | 18 | RDEPENDS:${PN} += " \ |
| 19 | python3-compile \ |
| 20 | python3-compression \ |
| 21 | python3-netclient \ |
| 22 | " |
| 23 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 24 | INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode" |
| 25 | |
| 26 | do_compile:class-native () { |
| 27 | python_flit_core_do_manual_build |
| 28 | } |
| 29 | |
| 30 | do_install:prepend:class-native() { |
| 31 | export PYTHONPATH="${S}/src" |
| 32 | } |
| 33 | |
| 34 | BBCLASSEXTEND = "native nativesdk" |