blob: 02974772233fea5feb62a8d683af71af92acf866 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "The tiny Init service for HyperContainer"
2DESCRIPTION = "The init Task for HyperContainer"
3
4LICENSE = "Apache-2"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc"
6
7inherit autotools-brokensep
8
9SRC_URI = "git://github.com/hyperhq/hyperstart.git"
10
11SRCREV = "ad48a3230836f59ada163659cde151a37522068b"
12PV = "v0.2+git${SRCREV}"
13
14S = "${WORKDIR}/git"
15
16CACHED_CONFIGUREVARS = "ac_cv_file__usr_include_linux_vm_sockets_h=true"
17
18do_install() {
19 install -d ${D}/var/lib/hyper/
20
21 install -m644 ${S}/build/hyper-initrd.img ${D}/var/lib/hyper/
22 install -m644 ${S}/build/arch/x86_64/kernel ${D}/var/lib/hyper/
23}
24
25FILES_${PN} += "/var/lib/hyper"