Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "The tiny Init service for HyperContainer" |
| 2 | DESCRIPTION = "The init Task for HyperContainer" |
| 3 | |
| 4 | LICENSE = "Apache-2" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=fa818a259cbed7ce8bc2a22d35a464fc" |
| 6 | |
| 7 | inherit autotools-brokensep |
| 8 | |
| 9 | SRC_URI = "git://github.com/hyperhq/hyperstart.git" |
| 10 | |
| 11 | SRCREV = "ad48a3230836f59ada163659cde151a37522068b" |
| 12 | PV = "v0.2+git${SRCREV}" |
| 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | CACHED_CONFIGUREVARS = "ac_cv_file__usr_include_linux_vm_sockets_h=true" |
| 17 | |
| 18 | do_install() { |
| 19 | install -d ${D}/var/lib/hyper/ |
| 20 | |
| 21 | install -m644 ${S}/build/hyper-initrd.img ${D}/var/lib/hyper/ |
| 22 | install -m644 ${S}/build/arch/x86_64/kernel ${D}/var/lib/hyper/ |
| 23 | } |
| 24 | |
| 25 | FILES_${PN} += "/var/lib/hyper" |