Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "interface to seccomp filtering mechanism" |
| 2 | DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp." |
| 3 | HOMEPAGE = "https://github.com/seccomp/libseccomp" |
| 4 | SECTION = "security" |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame] | 5 | LICENSE = "LGPL-2.1-only" |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=7c13b3376cea0ce68d2d2da0a1b3a72c" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 7 | |
| 8 | DEPENDS += "gperf-native" |
| 9 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 10 | SRCREV = "f33f95014b36f97b42f0c2290e96d5c31647ed10" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 11 | |
| 12 | SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.5;protocol=https \ |
| 13 | file://run-ptest \ |
| 14 | " |
| 15 | |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit autotools-brokensep pkgconfig ptest features_check |
| 19 | |
| 20 | REQUIRED_DISTRO_FEATURES = "seccomp" |
| 21 | |
| 22 | PACKAGECONFIG ??= "" |
| 23 | PACKAGECONFIG[python] = "--enable-python, --disable-python, python3" |
| 24 | |
| 25 | DISABLE_STATIC = "" |
| 26 | |
| 27 | do_compile_ptest() { |
| 28 | oe_runmake -C tests check-build |
| 29 | } |
| 30 | |
| 31 | do_install_ptest() { |
| 32 | install -d ${D}${PTEST_PATH}/tests |
| 33 | install -d ${D}${PTEST_PATH}/tools |
| 34 | for file in $(find tests/* -executable -type f); do |
| 35 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 36 | done |
| 37 | for file in $(find tests/*.tests -type f); do |
| 38 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 39 | done |
Andrew Geissler | 78b7279 | 2022-06-14 06:47:25 -0500 | [diff] [blame] | 40 | for file in $(find tests/*.pfc -type f); do |
| 41 | install -m 644 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 42 | done |
| 43 | install -m 644 ${S}/tests/valgrind_test.supp ${D}/${PTEST_PATH}/tests |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 44 | for file in $(find tools/* -executable -type f); do |
| 45 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools |
| 46 | done |
| 47 | # Overwrite libtool wrappers with real executables |
| 48 | for file in $(find tools/.libs/* -executable -type f); do |
| 49 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools |
| 50 | done |
| 51 | } |
| 52 | |
| 53 | FILES:${PN} = "${bindir} ${libdir}/${BPN}.so*" |
| 54 | FILES:${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug" |
| 55 | |
| 56 | RDEPENDS:${PN}-ptest = "coreutils bash" |
| 57 | |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 58 | PV = "2.5.4" |