blob: 6d0f669d535d5938fd3b9b81090fb70f69e53ade [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "pandas library for high-performance data analysis tools"
2DESCRIPTION = "pandas is an open source, BSD-licensed library providing \
3high-performance, easy-to-use data structures and data analysis tools for \
4the Python programming language."
5HOMEPAGE = "http://pandas.pydata.org/"
6LICENSE = "BSD-3-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=3f23c5c092b74d245d48eeef72bc3fd2"
8
Patrick Williamsde0582f2022-04-08 10:23:27 -05009SRC_URI[sha256sum] = "92bc1fc585f1463ca827b45535957815b7deb218c549b7c18402c322c7549a12"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010
11inherit pypi setuptools3
12
13DEPENDS += " \
14 ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
15"
16
17CFLAGS:append:toolchain-clang = " -Wno-error=deprecated-declarations"
18
19RDEPENDS:${PN} += " \
20 ${PYTHON_PN}-json \
21 ${PYTHON_PN}-numpy \
22 ${PYTHON_PN}-dateutil \
23 ${PYTHON_PN}-dateutil-zoneinfo \
24 ${PYTHON_PN}-pytz \
25 ${PYTHON_PN}-profile \
26"