Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Cherokee Web Server fast and secure" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 2 | SUMMARY:cget = "Small downloader based in the Cherokee client library" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 3 | HOMEPAGE = "http://www.cherokee-project.com/" |
| 4 | SECTION = "network" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 7 | |
| 8 | DEPENDS = "unzip-native libpcre openssl mysql5 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
| 9 | |
Brad Bishop | 87b3cb8 | 2019-11-15 16:35:37 -0500 | [diff] [blame] | 10 | SRCREV = "9a75e65b876bcc376cb6b379dca1f7ce4a055c59" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 11 | PV = "1.2.104+git${SRCPV}" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | SRC_URI = "git://github.com/cherokee/webserver;branch=master;protocol=https \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 13 | file://cherokee.init \ |
| 14 | file://cherokee.service \ |
| 15 | file://cherokee-install-configured.py-once.patch \ |
| 16 | file://0001-configure.ac-Add-foreign-to-AM_INIT_AUTOMAKE.patch \ |
| 17 | file://0001-make-Do-not-build-po-files.patch \ |
Brad Bishop | 87b3cb8 | 2019-11-15 16:35:37 -0500 | [diff] [blame] | 18 | file://0001-common-internal.h-Define-LLONG_MAX-if-undefined.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 19 | " |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 23 | inherit autotools-brokensep pkgconfig binconfig update-rc.d systemd ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)} |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 24 | |
| 25 | PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}" |
| 26 | PACKAGECONFIG[ffmpeg] = "--with-ffmpeg,--without-ffmpeg,libav" |
| 27 | PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap" |
| 28 | PACKAGECONFIG[geoip] = "--with-geoip,--without-geoip,geoip" |
| 29 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," |
| 30 | |
| 31 | EXTRA_OECONF = "--disable-static \ |
| 32 | --disable-nls \ |
| 33 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--enable-pam', '--disable-pam', d)} \ |
| 34 | --with-wwwroot=${localstatedir}/www/cherokee \ |
| 35 | " |
| 36 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 37 | do_install:append () { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 38 | install -m 0755 -d ${D}${sysconfdir}/init.d |
| 39 | install -m 755 ${WORKDIR}/cherokee.init ${D}${sysconfdir}/init.d/cherokee |
| 40 | |
| 41 | # clean up .la files for plugins |
| 42 | rm -f ${D}${libdir}/cherokee/*.la |
| 43 | |
| 44 | install -d ${D}${systemd_unitdir}/system |
| 45 | install -m 0644 ${WORKDIR}/cherokee.service ${D}${systemd_unitdir}/system |
| 46 | rmdir "${D}${localstatedir}/run" |
| 47 | rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" |
| 48 | } |
| 49 | |
| 50 | # Put -dev near the front so we can move the .la files into it with a wildcard |
| 51 | PACKAGES =+ "libcherokee-server libcherokee-client libcherokee-base cget" |
| 52 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 53 | FILES:cget = "${bindir}/cget" |
| 54 | FILES:libcherokee-server = "${libdir}/libcherokee-server${SOLIBS}" |
| 55 | FILES:libcherokee-client = "${libdir}/libcherokee-client${SOLIBS}" |
| 56 | FILES:libcherokee-base = "${libdir}/libcherokee-base${SOLIBS}" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 57 | |
| 58 | # Pack the htdocs |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 59 | FILES:${PN} += "${localstatedir}/www/cherokee" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 60 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 61 | CONFFILES:${PN} = " \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 62 | ${sysconfdir}/cherokee/cherokee.conf \ |
| 63 | ${sysconfdir}/init.d/cherokee \ |
| 64 | " |
| 65 | |
| 66 | INITSCRIPT_NAME = "cherokee" |
| 67 | INITSCRIPT_PARAMS = "defaults 91 91" |
| 68 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 69 | RPROVIDES:${PN} += "${PN}-systemd" |
| 70 | RREPLACES:${PN} += "${PN}-systemd" |
| 71 | RCONFLICTS:${PN} += "${PN}-systemd" |
| 72 | SYSTEMD_SERVICE:${PN} = "cherokee.service" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 73 | |
| 74 | python() { |
| 75 | if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split(): |
| 76 | raise bb.parse.SkipRecipe('Requires meta-python2 to be present.') |
| 77 | } |